Jump to content
Updated Privacy Statement
  • 1

VDA \ UPM 1912 Office 365 authentication issues


Question

We have recently upgraded our infrastructure to 1912 LTSR and are currenting deploying 1912 VDA to our Windows 10 random pooled desktops with UPM.  Since upgrading the VDA, our “office 365” apps, Onedrive no longer authenticate and auto configure them selves on a new user  profile creation. If launched manually and credentials are entered, the sign in\setup fails with multiple errors.

 

The Windows Event Application log is filled with the following errors:

AppModel-State

Triggered repair because operation LocalSettings against package Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy hit error -2147024891.

 

Repair for operation LocalSettings against package Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy with error -2147024891 returned Error Code: 0

 

Repair of state locations for operation SettingsInitialize against package Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy with error -2147024891 returned Error Code: 0

 

Repair for operation LocalSettings against package Microsoft.Windows.ContentDeliveryManager_cw5n1h2txyewy with error -2147024891 returned Error Code: 0

 

Repair of state locations for operation SettingsInitialize against package Microsoft.Windows.ContentDeliveryManager_cw5n1h2txyewy with error -2147024891 returned Error Code: 0

 

The Windows Event AAD log is filled with the following errors:

Error: 0x80070005 Access is denied.

 

Error trying to initialize the application data container server

Exception of type 'class WinRTException' at webaccountprocessor.cpp, line: 293, method: AAD::Core::WebAccountProcessor::ProcessBrokerBackgroundRequest::<lambda_81ac28c35853adf84b428032ff8e5a67>::operator ().

 

Log: 0xcaa5001c Token broker operation failed.

Operation name: DefaultUser

Logged at webaccountprocessor.cpp, line: 577, method: AAD::Core::WebAccountProcessor::ReportException.

 

 

Error: 0xCAAD0003 Canceled by background infrastructure. Reason: ServicingUpdate.

Exception of type 'class BICancelException' at webaccountprocessor.cpp, line: 268, method: AAD::Core::WebAccountProcessor::ProcessBrokerBackgroundRequest::<lambda_41162a7b4c42232d93d5b7a461ec5b61>::operator ().

 

Log: 0xcaa5001c Token broker operation failed.

Operation name: DefaultUser

Logged at webaccountprocessor.cpp, line: 577, method: AAD::Core::WebAccountProcessor::ReportException.

 

I have narrowed the issue to UPM.  If I disable the UPM GPO, everything works as expected, apps authenticate and are setup automatically.  If I rollback the VDA to 7.15 CU5 with UPM everything works.

 

An ideas as to what changed between the VDA versions or what could be causing the issue ?

 

Link to comment

5 answers to this question

Recommended Posts

  • 0

I think I may have found a solution but it will require furthur testing:

 

Checked !ctx_localappdata!\Packages on Enable Default Exclusion List - directories

 

Removed from Folders to mirror:

AppData\Local\Packages
AppData\Local\TileDataLayer
AppData\Local\Microsoft\Windows\Caches

 

Removed Files to synch

AppData\Local\Microsoft\Windows\UsrClass.dat*

 

My office 365 apps now launch and are setup correctly on 1st use.  Will have to test how the profile behaves on multiple logon \ logoff.

Link to comment
  • 0

Not yet.  Still waiting to hear back from support.  They collected information and are investigating.  The 2 forum posts below seem related to the issue i'm experiencing.

 

https://discussions.citrix.com/topic/406884-windows-10-modern-apps-breaking-wsappx/

 

https://discussions.citrix.com/topic/406752-citrix-vda-1912-break-our-file-type-associations-fta-and-has-other-issues/

 

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...