Jump to content
Welcome to our new Citrix community!
  • 0

citrix xendesktop DDC failover - doesnt work instantaneously


Kedar Pavaskar1709157578

Question

We have two Desktop Delivery Controllers running Xendesktop 7.15LTSR CU4, which host around 130 Non-Persistent VDI desktops.

 

Problem Description:

when one of the DDC is shutdown, the new sessions throw error "citrix xendesktop connection failed with status 1110", however after 5 minutes the new session starts to function fine.

during these five minutes i see the VDA machines are Re-registering with the next available controller. after all the VDA machines are available, i see no issues.

 

Concern is that we should not see 5-6 minutes of time waiting time. it has to instantaneous.

Please help with any inputs.

 

Link to comment

7 answers to this question

Recommended Posts

  • 1
1 hour ago, Kedar Pavaskar1709157578 said:

Is there any way I can make the probes between Netscaler and the STA faster? I see that when the STA is already down, the Netscaler takes at least 2-3 minutes to mark it down. 
I’m using NS 12.x
 

please advice 

Please try changing the interval of the Default STA monitor under Traffic management > load Balancing > Monitors .

i guess that could be causing the delay in probing the STA and marking it down, as the default value is 2 Minutes.

 

I've never changed interval myself, but please try doing so and update here.

 

  • Like 2
Link to comment
  • 0

Did some more troubleshooting and I see the issue is happening on the access gateway URL and not on the Storefront URL. 
when one of the DDC is down the storefront is still able to access all the desktops immediately, however the Netscaler is taking time to mark the STA as down. 
after the STA is marked as down by the NS, new connections start to work fine.

Link to comment
  • 0
9 minutes ago, Kedar Pavaskar1709157578 said:

Did some more troubleshooting and I see the issue is happening on the access gateway URL and not on the Storefront URL. 
when one of the DDC is down the storefront is still able to access all the desktops immediately, however the Netscaler is taking time to mark the STA as down. 
after the STA is marked as down by the NS, new connections start to work fine.

Is there any way I can make the probes between Netscaler and the STA faster? I see that when the STA is already down, the Netscaler takes at least 2-3 minutes to mark it down. 
I’m using NS 12.x
 

please advice 

Link to comment
  • 0
9 hours ago, Kedar Pavaskar1709157578 said:

Did some more troubleshooting and I see the issue is happening on the access gateway URL and not on the Storefront URL. 
when one of the DDC is down the storefront is still able to access all the desktops immediately, however the Netscaler is taking time to mark the STA as down. 
after the STA is marked as down by the NS, new connections start to work fine.

 

8 hours ago, Carl Stalhood1709151912 said:

Go to Traffic Management > Load Balancing > Monitors. There's a built-in STA monitor that you can edit.

thanks! This worked. 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...