Jump to content
Welcome to our new Citrix community!
  • 0

Can't uninstall Citrix Workspace App 1904


Thomas Gggg

Question

Hi,

I tried to update Citrix Workspace App from 1904 to 1911 on a PC Windows 10. I have to uninstall V1904 first but the uninstall process fails: Der Vorgang ist fehlgeschlagen (Process failed). Is there a proper, alternative method to remove the app manually via tools or do I have to remove all related files and registry entries myself ? I attached the protocol file of the failing attempt to uninstall the app.

 

 

TrolleyExpress-20200128-192645.log

Link to comment

2 answers to this question

Recommended Posts

  • 0

Hi,

 

Do you need to uninstall because you want to get rid of Citrix Workspace App? Or do you want to install a newer version?

If the former, I think you have two options:

  1. Install a newer version over this one (upgrade), then uninstall that newer version
    You can use the /forceinstall switch if it doesn't want to upgrade, it will essentially do a cleanup
  2. Use the Receiver Cleanup Utility:
    https://support.citrix.com/article/CTX137494
    Even though it's technically not made for Workspace App, and it's definitely deprecated, it will work on it.
     

If the latter, just do step 1. from above.

Best,

 

Koenraad

Link to comment
  • 0

I was able to get Citrix *mostly* uninstalled by running through the manual process described here: https://support.citrix.com/article/CTX325140. This involved deleting a lot of entries from the registry. The article misses the values in `HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\Uninstall`, which were essential for me to clear out to get Windows to recognize it as uninstalled.

 

But the better option was downloading a different version of the installer, running that, then uninstalling. The different version didn't stop running when it saw an existing version was already installed - it assumed you wanted to upgrade / downgrade. Then it would fix itself and could be uninstalled.

 

The `/forceinstall` option mentioned here (https://www.citrix.com/blogs/2019/10/02/still-using-receiver-cleanup-utility-its-time-to-move-on/) never worked for me in any capacity to try to clean things up. I was working with 21.3.1.25 (2103.1). Running in `cmd` with a normal or admin account, I was met with the same warning : "You already have this version of Citrix Workspace installed, so the installer will exit."

 

I'll note that even though Citrix can install and uninstall without errors, the intallation I have seems to be broken. Many required services are not installed when Citrix is reinstalled. The installer seems to think those components are already installed and skips them. The `ProgramFiles(x86)/Citrix` directory looks quite different from what it looked like in the first working installation. The end result is there are Citrix files on disk, but no Citrix app I can launch, no app associated with the receiver config file format, etc.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...