Jump to content
Welcome to our new Citrix community!
  • 0

XenDesktopServerSetup.exe Runs but never completes


Jonathan Clark1709155079

Question

Have a weird issue here.  Tried to upgrade my DDC from 1906 to 1912.  The installation completed and prompted for a reboot before the initialization.  After the reboot, the installation window will never come back up even if I run it manually. I can see XenDesktopServerSetup.exe running in Task Manager but the PID keeps changing every second.  Running it manually shows a blank black console window that never displays anything.  If you run a procmon it just shows it querying the same 100 registry/files over and over again but it not giving any access denied or failure messages.  Running it from the command prompt with a log location never generates a single log file.

 

To verify it wasn't an upgrade issue, I built a new server from scratch and tried to install fresh, the exact same problem happens after the very first reboot where C++ 2017 Runtime is installed.  The runtime is installed, I'm prompted for reboot, and when I come back, the rest of the installation will never launch, same issue with XenDesktopServerSetup.exe PID changing constantly.  I tried to do a fresh install of 1912 as well as 1906 and experience the same exact problem after the initial reboot.

 

Any ideas on what may cause this or a way to troubleshoot further?

Link to comment

8 answers to this question

Recommended Posts

  • 0
2 minutes ago, Kasper Johansen1709159522 said:

Hi,

 

Which OS are you running on your DDC?

Server 2016

 

2 minutes ago, Manbinder Pal Singh said:

Can you Share the metainstaller logs from %TEMP%\Citrix\Xendesktop Installation directory?

That is part of the problem, the logs don't generate after that first reboot. The logs end showing that that HKLM Run Once key was created and a reboot initialized.  After that, they never get touched again even when trying to force it through the command line.  If I specify a log directory in the command line, the log directory just stays empty.  I can confirm that the C:\ProgramData\Citrix AutoRun Waiting file does get created.  Deleting it does not help the progress move forward any either.

Link to comment
  • 0
41 minutes ago, Manbinder Pal Singh said:

Run the Scout tool and share the traces/bundle zip file.

Trying to avoid taking a trace at the moment as it would need to be scrubbed and can't be shared.

 

40 minutes ago, Manbinder Pal Singh said:

If VC runtime is installed by the installer then there has to be a metainstaller log file. May be check under %TEMP%\ Citrix and sometimes you have numeric subfolders ( 1,2,3 etc) under TEMP folder . Check under there as well.

I will try to find that log file but if I remember correctly, that log file shows everything is successful.  From what I have found it doesn't matter what is prompting the reboot, as soon as the installer requires the reboot and updates the C:\ProgramData\Citrix\XenDesktop Setup folder, we can never launch the installer again.  When we first tried, it was just the initialization that was left, when we tried with new installs, it was the VC that finished, but I believe the issue would persist even if we installed the VC manually and then did the next item that requires a reboot.  For some reason, after a reboot during the installation, we can never get the software to work anymore. 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...