Jump to content
Welcome to our new Citrix community!

EPA Plugin Failing to launch


Recommended Posts

Hello All,

 

I am experiencing problems with the EPA plugin on multiple client machines (all machines I have tried do not work).  I have an Nfactor policy to launch an EPA scan before any authentication takes place.  When browsing to the gateway I am prompted to download and proceed to install the EPA plugin.  This is successful.  However, I cannot get the actual scan to launch.  I get a message stating do I want to start nglauncher.exe, I click Yes and then get a message "We couldn't detect an EPA plugin on your system, please click on the download button to proceed"

 

I have tried various browsers and multiple clients, all with the same problem.

 

I'm not sure if I'm missing something here, does anyone any any pointers?

 

NS V12

 

Thank You

 

=========================
Launcher log 
Date: 01/27/2020
Time: 20:03:32
=========================
20:03:32.452 NOP got called 
20:03:32.504 getEPAVersion got called 
20:03:32.668 EpaCom::getEPAVersionCOM returned 12,0,63,13
20:03:32.678 getEPAVersion got called 
20:03:32.691 getEPAVersion got called 
20:03:32.792 getEPAVersion got called 
20:03:32.801 getEPAVersion got called 
20:03:32.811 getEPAVersion got called 
20:03:32.820 getEPAVersion got called 
20:03:32.833 getEPAVersion got called 
20:03:32.871 getEPAVersion got called 
20:03:32.884 getEPAVersion got called 
20:03:32.898 getEPAVersion got called 
20:03:32.910 getEPAVersion got called 
20:03:32.920 getEPAVersion got called 
20:03:32.929 getEPAVersion got called 
20:03:32.938 getEPAVersion got called 
20:03:32.947 getEPAVersion got called 
20:03:32.957 getEPAVersion got called 
20:03:32.966 getEPAVersion got called 
20:03:32.975 getEPAVersion got called 
20:03:32.984 getEPAVersion got called 
20:03:32.993 getEPAVersion got called 
20:03:33.002 getEPAVersion got called 
20:03:33.044 exit got called 
20:03:33.044 Closing NGlauncher because received exit request

 

 

=========================
nsepa.exe
Date: 2020-01-27
Time: 19:24:37
Version: 12.0.63.13
=========================
19:24:37.758 | DEBUG   | isUserActionRequired called
19:24:37.759 | DEBUG   | is_user_admin: Running as 'admin'
19:24:37.759 | DEBUG   | is_user_admin returning 1
19:24:37.759 | EVENT   | User is an admin.  No user action is required
 

Link to comment
Share on other sites

Hello,  

 

Just to add a little more detail to this:

 

NS v12.1 55.13, Hyper V Appliance

 

When I first tried configuring the EPA scan the clients all receive a message as follows in the browser:

 

You don't have permission to access /epa/scripts/win/nsepa_setup.exe on this server.

 

After checking KB I found this https://support.citrix.com/article/CTX263565 which identifies a possible corrupt plugin file.  However when browsing to /var/netScaler/gui/scripts/win I only saw epaPackage.exe.  This confused me, the NS is looking to download nsepa_setup.exe. 

 

I found that the NS12.0 HyperV applicate actually includes the files nsepa_setup.exe and nsepa_setup64.exe.  I have copied these files from NS12.0 to NS12.1 as suggested in the KB article, this has fixed the error "You don't have permission to access /epa/scripts/win/nsepa_setup.exe on this server." but the plugin is not recognised or launched.

 

I think I am missing something here, should NS12.1 be actually using epaPackage.exe and not nsepa_setup.exe ?

 

What is the difference epaPackage.exe just launches a command prompt and disappears quickly, where nsepa_setup actually installs the client EPA plugin.

 

Why would the NS be looking for nsepa_setup.exe, and why would it not be present in the 12.1 HyperV image.

 

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...