Jump to content
Welcome to our new Citrix community!
  • 0

Seamless application shows an incomplete and blurry window


Jochen Weber

Question

Hi,

 

we have a problem with an XenApp seamless application using ctrix receiver (4.12) on windows 10 (build 17763). The host system is a Windows Server 2016 with the VDA Version 7.15.1000. On the citrix delivery controller the same version is installed.

Sometimes the application window comes up incomplete and with blurry text, as you can see in the following screenshot (I blackened our sensible company data).

Blurry_Window.thumb.JPG.2b1c8c96fc7de6b62ef83b6b0d8a2944.JPG

 

The text in the menu bar is blurry and at the bottom of the window no copyright information comes up. The software is a multi window application and this behaviour is totally random and doesn't depend on the actual window.

It seems if we resize the affected window, the dialogue is re-rendered. After this everything looks correct (sharp and with copyright informations).

2025728990_CorrectWindow.thumb.JPG.3920a3144719b7a8f882e0d357bf77f1.JPG

 

We tried different configurations for "high dpi scaling" and compability modes of windows.  But nothing has an effect on this behaviour.

The legacy graphics mode fixed the problem, but is not supported for windows server 2016. If we use this mode the mouse pointer disappears.

 

Till now we used  Windows Server 2008 as the host system. On this we don't have this issue.

We also don't have this problem if we use XenDesktop.

 

Thanks in advantage

 

Jochen

Link to comment

2 answers to this question

Recommended Posts

  • 0

Hi Koenraad,

 

first of all, sorry for my late response. I was really busy last week.

 

Here are the group policie settings for the VDA:

 

Computer-Settings:

 

Enhanced Desktop Experience – Disabled

Maximum allowed color depth – 16 bits per pixel

 

User-Settings:

 

Preferrd color depth for simple graphics - 16 bits per pixel

Target Minimum Frame Rate – 20 fps

Use video codec for compression – For the entire screen

Visual Quality – Always Lossless 

Framehawk Display Channe – Disabled

 

The client settings for the citrix receiver are:

Let the operating system scale the resolution (here we tried the different settings)

Scaling in Windows 10 is 100%

 

I hope this helps to find a solution. Please let me know, if you need other informations.

 

Best regards,

Jochen

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...