Jump to content
Welcome to our new Citrix community!
  • 0

Action Center broke in 1909 update?


Darin McClain

Question

Action center works fine on the deployed machine for the local Administrator account. For any domain user that logs in though, it does not work. I even tried deleting the user layer disk so it would make a new one, it still doesn't work. Anyone run into this issue too?

 

More testing I've done:

User A & B, just plain domain users. Doesn't work with fresh or existing user layer.

User C, domain user with roaming profile. Doesn't work.

User D, domain admin with roaming profile. Does work! ???? (works for both fresh or existing user layer)

I added User A to the domain admin group, did not fix it with existing user layer or new one.

Made User A AD account match user D in every way, OUs, members of, etc. Doesn't work.

Made a brand new user. Doesn't work.

Had my co-worker login with his account, also a domain admin, though no roaming profile. Does work!! ??? :(

 

Edited by dmcclai286
Link to comment

9 answers to this question

Recommended Posts

  • 0

Yes I am. I even deleted my latest OS version that had 1909 installed in and tried re-doing 1909 all over again (from 1809), still no dice though.

 

So far I have 4 accounts that work, myself and 3 coworkers. And I have 5 accounts that don't work. Weird part is the 5 that don't work are either dummy accounts or secondary accounts. I have no clue why the "real people" accounts work and the others do not.

Link to comment
  • 0

Is there a simple way to disable layering via the registry? Like when I change the location of the shares?

 

I have logged in several ways with an account, we'll say "Robert", to this machine that I have updated to 1909.  Once while the Robert was logged in already elsewhere, so it couldn't use the existing user layer. Once after logging in with a different account, triggering the "not shutdown properly message". And once as it should be used, refreshed. All 3 scenarios the action center works fine for "Robert". When we try with my test account, action center doesn't work in any 3 of these scenarios.

 

We're about out of ideas here, so I'll probably open a ticket soon once I try it without layering.

Link to comment
  • 0

I had the idea of checking the assigned layer differences between the working and non-working accounts, so I haven't put in a ticket yet. I found something!

 

Sure enough, my Active Directory layer (Remote Server Administration Tools) triggers the behavior! It's triggering something upon the first login to a 1909 machine that makes the action center work. It does so whether there's no user layer, or there's an existing 1809 user layer.

 

If you don't have this layer assigned at first login, Action Center will be broken. Oddly enough, you cannot fix the Action Center it by simply adding the layer at this point, you will have to delete the user layer first so that's it's available on the first login to 1909. Once the first login is done and Action Center is working, you can remove this layer and Action Center will continue to work.

 

Another note, 5 or so app default reset notifications appear in the action center when the Active Directory layer is used. You don't see them when the Active Directory layer is not used. I'm not sure if these just don't occur at all when the layer is not used, or you just don't see them because the action center isn't working properly, haha.

 

Any thoughts on all that? I was thinking of booting up my platform layer based on 1909 to see if action center works. If it does, maybe a new image published with an updated platform layer might help? I have not updated any app layers with 1909 as the OS layer so it's confusing to me why the Active Directory layer triggers this behavior. I don't know if any other layers will do the same, but at least 7 other layers I know of do not.

Link to comment
  • 0

You could try creating a new version of the Platform layer, since you appear to have done a major OS upgrade. 

 

Is the layer in question delivered as an elastic layer? Yes, add it to the published image and test. No, ok.


We recommend the RSAT tools be installed in the OS or Platform Layer. One of our recent updates fixed an issue with RSAT being installed in the Platform Layer, but even then we prefer anything OS related be installed in the OS layer. Also testing with the least number of layers, to determine if a conflict exists, is best.

 

If this is not resolved, I must request you open a case for assistance.

Link to comment
  • 0

Making a new version of the Platform layer based on the new 1909 OS Layer did not work. I put in a ticket today and will post again when we figure it out!

 

And yes, these layers are delivered elastically. The RSAT is something I'd prefer not to have in the OS layer. Trying to just have one OS layer for everything student and staff. It's been working great so far. Just weird it being elastically delivered is actually fixing my issue, haha. I have also tried no layers delivered elastically, still action center refuses to work. :(

 

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...