Jump to content
Updated Privacy Statement
  • 0

WEM - StoreFront Shortcuts - Not Launching


Paul Cross

Question

Hi All.

 

Having an issue where my published SF shortcuts through created through WEM aren't launching. I've created them, assigned them so they appear and all looks good. Double click the icon and I can see the LaunchXenAppCmd.exe appear in the process list but then it disappears and nothing starts,

 

Here's a copy of the shortcut details:

"C:\Program Files (x86)\Citrix\Workspace Environment Management Agent\LaunchXenAppCmd.exe"  "APP-A" "https://internal.domain.com/Citrix/Store/Discovery" "C:\Program Files (x86)\Citrix\Workspace Environment Management Agent" 

 

Workspace App is configured for single sign on. If I launch the app through that all works fine.

 

This is happening on both a Windows 2019 Desktop and Windows 2008R2 Desktop. They are both running the latest 1912 release.

 

Regards. Paul.

Link to comment

5 answers to this question

Recommended Posts

  • 0

The issue is code related. In WEM 1912 shortcuts created using Storefront URL in WEM are added in user session, but do not launch published applications. 
Issue will be fixed in future release. If anyone needs the test version of fix for WEM 1912, please open a ticket in Citrix support.

 

Regards,

Monika

  • Like 1
Link to comment
  • 0

Hi Paul,

 

Not sure if this is related, but could it have something to do with the option "Enable (Virtual) Desktop Compatibility"?

See: https://www.mycugc.org/blogs/cugc-blogs/2018/01/04/wem-advanced-guidancepart-2-user-interaction

This thread also seems to be related to your issue:

https://discussions.citrix.com/topic/387785-start-a-published-application-using-wem/

 

Best,

 

Koenraad

Link to comment
  • 0

Hi Koenraad.

 

Thanks for your reply. I came across that thread also and ended up creating the shortcuts in the same way via selfservice.exe and the qlaunch parameter. In fact I actually prefer that way of doing to the native WEM integration with StoreFront due to the requirement for Citrix Receiver.

 

Not to sure were the Enable (Virtual) Desktop Compatibility comes in. I'll have another read tomorrow.

 

Regards. Paul.

Link to comment
  • 0
3 minutes ago, Paul Cross said:

Hi Koenraad.

 

Thanks for your reply. I came across that thread also and ended up creating the shortcuts in the same way via selfservice.exe and the qlaunch parameter. In fact I actually prefer that way of doing to the native WEM integration with StoreFront due to the requirement for Citrix Receiver.

 

Not to sure were the Enable (Virtual) Desktop Compatibility comes in. I'll have another read tomorrow.

 

Regards. Paul.

 

Hi Paul,

 

Glad to hear you were able to get it working with SelfService.exe.

I think the "Enable (Virtual) Desktop Compatibility" is needed when running WEM on Virtual Desktops, which it sounded like you do.
But I suppose it's not relevant anymore, now that you've found a solution/workaround.
 

Best,

 

Koenraad

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...