Jump to content
Welcome to our new Citrix community!
  • 0

LVM full with huge virtual allocation


Alan Souza

Question

Hi all, i have a Xenserver 7.6 in Dell R420. The sum of disks of VMs does not reach 3TB in LVM but show me 99% usage with  huge virtual allocation like image attached.

On "lvscan | grep inactive" i have many fragments and so many base copy.Can i delete them?

Reclaim free space doenst work with error in image attached.

 

LVM.JPG

Edited by alan.souza
new image attached
Link to comment

11 answers to this question

Recommended Posts

  • 1

You should not let an LVM volume get more than something like 85% full, as it will not be able to coalesce and get cleane up im such a state. You can get away with a lot of virtual over-allocation on thin-provisioned volumes,bit not for thick ones.

Your best bet would be to probably either (1) try to move some of the storage at least temporarily to a different SR so that more space is hopefully freed up or if that isn't possible, (2) plan for some down time and export at least some of the VMs, hopefully then clean up the disk, and then restore them back.

 

You have to be very careful about what you delete to make sure you do not accidentally destroy something that should not be. If you have long snapshot chanins, you could start by deleting snapshots but with the R this full, it still may not be able to clean itself up. YOu may be able to use vhd-util (see https://support.citrix.com/article/CTX139224) to help identify objects that can be safely deleted.

 

-=Tobias

  • Like 1
Link to comment
  • 1

Coalescing will always be an issue in any release if the SR is too full. I have seen this sort of thing happening over all the range of XS/CH releases. Upgrading from 6.5 at this point is something you should seriously consider, especially regarding concerns about security and performance updates that have taken place in the interim.

 

-=Tobias

  • Like 1
Link to comment
  • 0

So i moved 3 VMs to NFS BKP teste, LVM still 88% free but after days full again. Now i added arsstorage_nfs (NFS storage on Dell R230) to moved all VMs (merge in NFS BKP = QNAP and others VMs in R230) to clear LVM local. This Xen has upgrated from Xen 6.5. Some bug like this in older version of Xen?

Link to comment
  • 0
Quote

Coalescing will always be an issue in any release if the SR is too full. I have seen this sort of thing happening over all the range of XS/CH releases. Upgrading from 6.5 at this point is something you should seriously consider, especially regarding concerns about security and performance updates that have taken place in the interim.


Now i'm in 7.6. I said that this Xenserver has been updated since version 6.2 or 6.5 without a clean installation

Below the vhd-util-scan of my LVM

log-vhd-util-scan.txt

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...