Jump to content
Welcome to our new Citrix community!
  • 0

NTP service is not exist in Hypervisor 8.1


Sergey Polyakov

Question

20 answers to this question

Recommended Posts

  • 0

 Chrony by default is not synchronized if the time difference exceeds 3 s.

 

Explanation https://bugzilla.redhat.com/show_bug.cgi?id=1525833

 

Solution:

1. Manual set time if Offset more than 1 min.

 date -s '2020-01-14 12:09'

2. Add  maxdistance  60 sec parametr in /etc/chrony.conf

maxdistance 60 

3. Restart chronyd service

systemctl restart chronyd

 

 

Checking:

chronyc tracking

........

Leap status     : Normal
 

chronyc ntpdata

........

Offset          : +0.004829173 seconds

 

 

 

  • Like 1
Link to comment
  • 0

I try install ntp from 8.0 ISO 
 

rpm -Uvh /mnt/cd/Packages/ntp-4.2.6p5-28.el7.centos.x86_64.rpm 
warning: /mnt/cd/Packages/ntp-4.2.6p5-28.el7.centos.x86_64.rpm: Header V4 RSA/SHA1 Signature, key ID 6e12e8fc: NOKEY
error: Failed dependencies:
libopts.so.25()(64bit) is needed by ntp-4.2.6p5-28.el7.centos.x86_64
ntpdate = 4.2.6p5-28.el7.centos is needed by ntp-4.2.6p5-28.el7.centos.x86_64
ntp is obsoleted by (installed) xs-obsolete-packages-1-4.noarch

Link to comment
  • 0

I found, now it's chrony

 

But time sync not work.

chronyc tracking
Reference ID    : 00000000 ()
Stratum         : 0
Ref time (UTC)  : Thu Jan 01 00:00:00 1970
System time     : 0.000000000 seconds fast of NTP time
Last offset     : +0.000000000 seconds
RMS offset      : 0.000000000 seconds
Frequency       : 0.000 ppm slow
Residual freq   : +0.000 ppm
Skew            : 0.000 ppm
Root delay      : 1.000000000 seconds
Root dispersion : 1.000000000 seconds
Update interval : 0.0 seconds
Leap status     : Not synchronised

 

 chronyc sources
210 Number of sources = 2
MS Name/IP address         Stratum Poll Reach LastRx Last sample               
===============================================================================
^? server1        2  10   377   494  +28549s[+28549s] +/-  10.8s
^? server2          2  10   377   494  +28549s[+28549s] +/-  10.8s

 

I try:

chronyc -a 'burst 4/4'

chronyc -a makestep

result: time Not synchronised +8 hours

 

 

Link to comment
  • 0
31 minutes ago, Alan Lantz said:

Glad you found a fix. I wonder why NTP was dumped? Especially if Chrony

doesn't seem to be as good.

 

--Alan--

 

Perhaps for this:

Citrix Hypervisor have been updated to use CentOS 7.5 as their base operating system
RHEL 7.x default environment uses the newer Chrony daemon (chronyd) instead.

 

Link to comment
  • 0
2 minutes ago, Carl Webster1709152473 said:

Where did you see that? All I see in the release notes is "The Citrix Hypervisor platform has been updated to use Xen hypervisor version 4.13".

 

I see nothing in the Deprecations and Removal notes about NTP removal.

This was in previous release Citrix Hypervisor 8.0 CR

https://docs.citrix.com/en-us/citrix-hypervisor/8-0/downloads/citrix-hypervisor-8.0.pdf
https://www.thegeekdiary.com/centos-rhel-7-chrony-vs-ntp-differences-between-ntpd-and-chronyd/

 

Link to comment
  • 0

NTP seems to be in timedatectl in version 8.1

 

-xen-005 ~]# timedatectl status

      Local time: Thu 2020-01-16 07:37:44 CET
  Universal time: Thu 2020-01-16 06:37:44 UTC
        RTC time: Thu 2020-01-16 06:37:44
       Time zone: Europe/Stockholm (CET, +0100)
     NTP enabled: yes
NTP synchronized: yes
 RTC in local TZ: no
      DST active: no
 Last DST change: DST ended at
                  Sun 2019-10-27 02:59:59 CEST
                  Sun 2019-10-27 02:00:00 CET
 Next DST change: DST begins (the clock jumps one hour forward) at
                  Sun 2020-03-29 01:59:59 CET
                  Sun 2020-03-29 03:00:00 CEST
-xen-005 ~]#

 

/n

 

 

 

Link to comment
  • 0
42 minutes ago, NIcklas Ryden1709161360 said:

NTP seems to be in timedatectl in version 8.1

 

-xen-005 ~]# timedatectl status

      Local time: Thu 2020-01-16 07:37:44 CET
  Universal time: Thu 2020-01-16 06:37:44 UTC
        RTC time: Thu 2020-01-16 06:37:44
       Time zone: Europe/Stockholm (CET, +0100)
     NTP enabled: yes
NTP synchronized: yes
 RTC in local TZ: no
      DST active: no
 Last DST change: DST ended at
                  Sun 2019-10-27 02:59:59 CEST
                  Sun 2019-10-27 02:00:00 CET
 Next DST change: DST begins (the clock jumps one hour forward) at
                  Sun 2020-03-29 01:59:59 CET
                  Sun 2020-03-29 03:00:00 CEST
-xen-005 ~]#

 

/n

 

 

 

 I tried to find a solution for the error "The clock on server is not synchronized with the other servers in pool"

In earlier versions, this was solved using the command "ntpdate server" CTX226572
if you can give instructions how to force time synchronization with ntp server using timedatectl, that would be great.

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...