Jump to content
Welcome to our new Citrix community!
  • 1

Outlook Search Fix


Roger Stuart1709157773

Question

I wanted to take a few minutes to report some good news.  For over a year now we’ve been trying to fix issues with the search feature not working in O365.  We tried every suggestion listed in the Forums as well as a few others that we came up with.  None of them worked until we updated App Layering to version 1911.  I believe this fix is also in 1910 but we skipped over that one. 

 

Overview

Windows Server 2016 (over 300 App Layered Machines with O365)

App Layering 19.11.0.20

Office 365 version 1902

UPM 1811

UPM VHDX-based Outlook

 

Issues

Outlook search did not return any results

Outlook search returned results but displayed “Something went wrong” (Our most common problem)

Many “OutlookSearchIndex” vhdx files grew to 10 – 50 GB

 

How we fixed it

Upgraded all our ELMs to 1911 (We are not using offload compositing at this point due to an issue with it ignoring the settings we added for our machines to have a 50 GB writable partition)

Versioned our O365 layer and reran the Optimizer 

Redeployed new images to all our 2016 Servers

After rebooting the servers we ran a script that deleted the “OutlookSearchIndex” vhdx from every one of our users’ profiles on the various profile shares. When the users logged back in the Search Index rebuilt itself and as of right now it appears the largest ones are in the 2 – 4 GB range and they seem to have stopped growing. 

 

Outlook Search is now working and we no longer see the "Something went wrong" error message.  

Link to comment

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...