Jump to content
Welcome to our new Citrix community!

Cannot Launch Citrix Apps After StoreFront SSL Certificate Expired


Michael J. Thurgood

Recommended Posts

XenApp 6.5, StoreFront 2.5, NetScaler VPX 10.5 68.7.nc:

Connections through the NetScaler have been successful for many months.  The SSL Certificate on the StoreFront server was approaching expiration.  A new certificate was acquired and installed and attached to the https binding.  Connections through the NetScaler continued to function until today, when the old certificate expired.  Now, employees can log in to the NetScaler, but when they try to launch applications they receive the following error messages, "Unable to launch your application.  Contact your help desk with the following information: Cannot connect to the Citrix XenApp server.The Citrix SSL server you have selected is not accepting connections." and "The connection to '<published app>' failed with status (Unknown client error 0).

 

I'm guessing that the old certificate is still tied to something in the NetScaler, but I can't find anything.  When renewing the SSL Certificate on the StoreFront server, are there other steps besides importing the certificate into Server Certificates and adjusting the https binding to use the new certificate?

Link to comment
Share on other sites

Is the new certificate issued by the same CA as the old one? If not, you probably also need a new intermediate certificate.

Are you using an SSL VIP to access StoreFront? If you have the StoreFront certificate bound to the VIP, you will also need to upload the new certificate to the NetScaler (together with any needed intermediate certificates). 

Link to comment
Share on other sites

Thank you for your response on a holiday weekend!  It turned out to be a networking issue in which the NetScaler Gateway could not reach the STA on one of the XenApp servers.  Apparently, it was an amazing coincidence that the issue occurred on the same day that the old StoreFront SSL certificate expired.  The article "Secure Ticket Authority Shows Down in NetScaler" got me on the right path towards resolving the issue:  https://support.citrix.com/article/CTX132334.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...