Jump to content
Welcome to our new Citrix community!

nsgclient18_64.deb is not a valid


Mathias Gebbe

Recommended Posts

I tested the new client https://www.citrix.com/de-de/downloads/citrix-gateway/plug-ins/netscaler-gateway-plug-in-VPN_EPA_Clients_Ubuntu_18.html
but it seems not to be a valid debian/ubnutu package
➜  netscaler sudo dpkg -i nsgclient64.deb
dpkg-deb: file looks like it might be an archive which has been
 corrupted by being downloaded in ASCII mode
dpkg-deb: error: 'nsgclient64.deb' is not a Debian format archive
dpkg: error processing archive nsgclient64.deb (--install):
 dpkg-deb --control subprocess returned error exit status 2
Errors were encountered while processing:
 nsgclient64.deb

Selection_999(904).png

Link to comment
Share on other sites

  • 3 weeks later...

Indeed.  I am running into the same issue as well.  It seems that we might need different deb files uploaded and verified by the Citrix gods.  Maybe if we offer them humble blessings, they will take pity upon us...  I offer the attached deb files for the Citrix gods to test.

nsgclient64.deb nsgclient18_64.deb

 

The SHA256 checksum (d66d67dd8da6c2e6bd9bedf8288b37e988d9359948e0b5bf27cee7e393016105) matched the nsgclient.zip file that I downloaded from here...

https://www.citrix.com/downloads/citrix-gateway/plug-ins/netscaler-gateway-plug-in-VPN_EPA_Clients_Ubuntu_18.html

  • Like 2
Link to comment
Share on other sites

Hi guys,

 

I looked into this issue and it seems like the package itself has an issue.

I ran the install with dpkg and apt, and it seems that the package is somewhat malformed.

 

The fix should be available in the next days, but I can't promise anything.

 

Kind Regards,

Téo

  • Like 1
Link to comment
Share on other sites

image.thumb.png.ff2341584d58c8d54cd339f548f43a95.png

 

Just tested it on both Ubuntu 19.10 and 18.04 with all packages updated before.

Worked on 18.04.3, but not on 19.10.

 

There seems to be some version incompatibilities for certain packets with 19.10.

Also, based on the fact that apt gave me way more info on the package than just dpkg that told me the package was just malformed, I'm pretty sure that you guys should install this using apt instead.

Link to comment
Share on other sites

Hey guys,

 

This is still not working for me.

 

It is working in windows when I access the following link,

 

https://virtualaccess.adp.com/epa/epa.html

 

But in my main ubuntu installation, no joy.

 

I've removed all previously installed packages and installed the above mentioned newer ones.

 

I've attached a screenshot of the error I get. My browser does ask me if I want to open-xdg application, and I say yes.

 

Any ideas?

 

Screenshot from 2020-01-20 13-24-11.png

Link to comment
Share on other sites

3 hours ago, Rudolf Liebenberg said:

Hey guys,

 

This is still not working for me.

 

It is working in windows when I access the following link,

 

https://virtualaccess.adp.com/epa/epa.html

 

But in my main ubuntu installation, no joy.

 

I've removed all previously installed packages and installed the above mentioned newer ones.

 

I've attached a screenshot of the error I get. My browser does ask me if I want to open-xdg application, and I say yes.

 

Any ideas?

 

Screenshot from 2020-01-20 13-24-11.png

 

The link that troeweka posted below now works for me ("NetScaler Gateway nsgclient for Ubuntu 18")...

https://www.citrix.com/de-de/downloads/citrix-gateway/earlier-versions/netscaler-gateway-plug-in-VPN_EPA_Clients_Ubuntu_18.html?_ga=2.154674426.370093300.1579530233-387557861.1553203813

 

I'm using Ubuntu 16.04 and Chrome.  If you look at the system requirements, there is a caveat for Ubuntu 16.04...

"IMPORTANT:Due to a bug (1573408) in Ubuntu 16.04 LTS, the VPN Gateway plug-in installation fails. The workaround for the same is listed as follows.."...

https://docs.citrix.com/en-us/netscaler-gateway/12/system-requirements/plugin-system-requirements.html

 

I just accepted the "open-xdg application" prompts from Chrome and let it percolate.  After you're authenticated, run ifconfig on your terminal to see if you're pulling an ip on your new Citrix interface.  I can ping out through the VPN just fine, but you'll need to address DNS to make sure that's resolving...

 

Link to comment
Share on other sites

  • 2 years later...
On 1/20/2020 at 4:55 PM, Rudolf Liebenberg said:

Hey guys,

 

This is still not working for me.

 

It is working in windows when I access the following link,

 

https://virtualaccess.adp.com/epa/epa.html

 

But in my main ubuntu installation, no joy.

 

I've removed all previously installed packages and installed the above mentioned newer ones.

 

I've attached a screenshot of the error I get. My browser does ask me if I want to open-xdg application, and I say yes.

 

Any ideas?

 

Screenshot from 2020-01-20 13-24-11.png

 

Were you able to fix this issue? Do we have a thread on this behavior, were installation is fine, but would not launch the client?

 

I am using the new version listed in downloads (NetScaler Gateway nsgclient version 1.0.0.146 for Ubuntu 18) on Ubuntu 18.04.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...