Jump to content
Welcome to our new Citrix community!
  • 0

Server 2019 VDA black screen for 30 minutes


Carlo Encinareal1709158749

Question

We have a relatively new (just a bit over a month) CVAD 1909 deployment using server 2019 as VDAs. We have application only VDAs and published desktop only VDAs separately. We are also leveraging Microsoft APP-V to deliver the application on said VDAs. From the time we implemented this, we have had issues where the published desktop VDAs will just sit on a black screen for about 30 minutes before it displays the desktop. This happens intermittently and no way to tell which VDA will exhibit this behavior. The only solution we have is to put the VDA in maintenance mode and bleed out the users and reboot. This seems to happen once to each VDA within a 24 hour period. We also resorted to a daily reboot just because of this.

 

If we try to RDP to the affected VDA, we get the same black screen issue. Even going to the VDA console (we use Citrix Hypervisor 8.0) and logging on as a local admin, same issue. I'm able to pull up task manager from the console and see users still connected to it and appear to still be functioning normally until the other day that I noticed when I tried to just keep RDP sessions running to all of the VDAs and waited until the issue comes up. Then I noticed that my connected RDP session that I could not even invoke windows explorer. So it would seem any current user session is unable to interact with the published desktop. I checked CPU and Memory usage during this time and it seems normal. This also happens on published applications from the application only VDAs but users only see it as the application not starting up since it's unable to proceed normally with the login process. Same thing when we check on the application VDA console, just getting a black screen for 30 minutes.

 

We found this Microsoft forum article that pretty much describes what we're seeing only this is just referring to windows host terminal servers (which Citrix VDAs are).

https://social.technet.microsoft.com/Forums/en-US/c3458db3-6e69-495d-aa19-98d232aef3ad/rds-30-min-to-show-desktop-black-screen?forum=winserverTS

 

We have tried other suggestions (mostly registry hacks) of other "black screen" issues that we found on other forums although those mainly describe a brief black screen that pops up when launching a session.

 

Any ideas what this could be or has anyone else encountered this issue in their deployment? Obviously, our user base is not happy with all of the work interruption so any help from this community will be greatly appreciated.

Link to comment

1 answer to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...