Jump to content
Welcome to our new Citrix community!
  • 1

Cannot connect to Citrix Workspace on new macOS Catalina


Jennifer Martin

Question

I am getting the message "Citrix Workspace cannot connect to the server. Check your network connection." when I try to sign in. I am currently using macOS 10.15 (Catalina). I am also running Citrix Workspace App version 19.10.2.41. The Java version I have is version 8 update 231. I was able to connect to Citrix prior to the macOS update to Catalina. The latest update for Citric Workspace App says it is compatible with macOS 10.15. Has anyone else had this same issue?

Link to comment

11 answers to this question

Recommended Posts

  • 2

I had same issue and this is how I got it to work. 

Normally in my "office" we didn't need to enter an address in workspace and it connected fine after  login - . But for this user that was having the issue I ended up entering the server address

223237444_ScreenShot2021-03-16at3_52_24PM.thumb.png.9ea19bce14a75c04383d8a1ff5047602.png

and then in my case AccessGatewaySF.

56915179_ScreenShot2021-03-16at3_52_05PM.thumb.png.1fd7b201ac7a32a6dc92104350b51203.png

I noticed in preference under Accounts  it was also auto-entering and activating "Internal" - I unchecked Internal - leaving just the accessgatewaysf (in her case - pic is for reference) and it worked fine.

1624710377_ScreenShot2021-03-16at3_54_00PM.thumb.png.8d02420b77948bbdbfc49f79b7a3c008.png

Maybe you are experiencing something like this and this helps in troubleshooting... 

  • Like 2
Link to comment
  • 0

Hello, bumping this thread because at least someone was kind enough to offer some support. I am having a similar issue. I am running MacOS Catalina 10.15.3 and Citrix Workspace 20.02.0.5 (2002). 

 

I added that certificate provided above to my keychain and I'm still have issues. I can log into my server and connect to the program I need to launch, but when I try to launch the program, I get an error stating: "Connection to server ____ was interrupted. Please check your network connection and try again." 

 

 

Additionally, when I try to open the "launch.ica" file for the server, I get this error: 1411142721_ScreenShot2020-03-16at9_12_33AM.thumb.png.0d65b0cfc9b5a8ae75d13179cfce094e.png

 

Any help would be GREATLY appreciated. Really need access to this database and do not have access to my office for the foreseeable future.  Thank you. 

Link to comment
  • 0

The problem may be with the Netscaler or Storefront configuration, I suggest you contact your Citrix Support group and see if they are willing to offer any help.   In my current environment we have one Storefront/Netscaler pair where some versions of MacOS fail to connect but if I send the user to another URL hitting a different Storefront they work fine.  Not being a Mac user, that's about all I've got to offer at this point.

Link to comment
  • 0

Thank you so much for your speedy reply.  I am not an advanced Citrix user by any means and am doing my best to troubleshoot because our IT department has been having issues and I'm really trying to avoid traveling within New York City with all that is going on.

If you don't mind me asking a seemingly basic question, is the Citrix Support group something that would be linked to me via my organization (if so, I don't believe I have one--I signed up for an account as a last ditch effort to fix this myself), or is it simply support through this website? 

 

What I will say is that colleagues of mine with Macs running OS 10.14 using this software/server are not having any issues, so it appears that something changed with the update to 10.15.  I'll read up on how the Storefront functions and see if I can work it out from there (like I said, I'm a novice.)

 

Thanks again. I really appreciate you taking the time to help. 

Link to comment
  • 0

Storefront is the Website you go to to launch applications (Unless you use the Workspace application directly).  Netscaler is a gateway device that your company may or may not use, they could be using any manor of load-balancing gateway device, but in any case it would need to properly support the SSL/TLS ciphers being used when your PC connects to the environment .  These are both backend services that you would not have any access to.   With many companies sending workers home to work, your companies IT staff is probably a bit busy as is the case with my group. At any rate, you need to open a ticket with your company IT team to see if they can offer any suggestions, it's possible that they've not kept the company Citrix environment up to date and your version of Citrix Workspace no longer supports the older SSL ciphers still being used in your environment.  I know we have users (running Windows) where we've had to roll them back to an older version of the software so that they can access a third-party Citrix environment.  Not a desirable situation, but one I have to support.  

Link to comment
  • 0

Okay, thanks. Yes, I put in a website as the server address, and then I am able to at least see the application I am trying to launch, but am unable to launch it without a server connection error, and using the launch.ica creates an error, too. 

 

Based on what you're saying, unfortunately I don't think it is anything my agency's IT department would have access to either, but rather is an issue with a program that is coming from a much larger organization that has a lot on its plate right now.  Most likely that they have not kept it up-to-date for Mac, as most work within this field is done on Windows. I am just trying to use my personal computer for work access considering the circumstances, which is why this hasn't been an issue up until now. 

 

Thanks so much for your help. I really appreciate it. Stay well. 

Link to comment
  • 0

Having the same issue connecting Workspace app on macOS Catalina. "Citrix Workspace cannot connect to the server. Check your network connection."

 

MacOS Catalina 10.15.4    and   Workspace App 20.02.0.5. and other Mac with Workspace app 19.12.0.23

 

It has to be an issue with the latest Catalina updates.  There have been no changes to our Hypervisor, Storefront, Netscaler, App Servers.  Only changes were updates in Catalina and updates to Workspace.  

 

Several other users that have updated their MacBooks to Catalina 10.15.4 AND have not updated Workspace have the same issue. 

 

Hoping someone has a solution.  Apple support shrugs their shoulders and says it is an issue with the Workspace app.

 

 

Link to comment
  • 0

I will add that I've had a few people that while using Safari they could not connect, found that using Chrome, the applications would launch, so that's worth a try if you haven't already.  A lot of this is dependent upon the environment you're connecting to, are they running recent versions of the Citrix Backend components and assuming there is a Netscaler in the picture, is that fairly up to date.  If you're running a recent version of Workspace, connecting to an outdated environment won't work due to the fact that Citrix have deprecated old SSL Ciphers that are deemed unsafe.  Workspace versions for MacOS  are pretty specific as to the OS version, so rolling back to a previous version of Workspace may be difficult.  I think Workspace on MacOS has been a moving target for the past year or so, every update has required an update to Workspace.  Ideally, Citrix would have an LTSR version that like on Windows, keeps the same functionality but receives security fixes.  I did a brief check on that last week but came up empty handed. 

 

Unfortunately Apple support seems to not care much about their OS being supported in terms of Enterprise use, they will make some change that apparently isn't communicated to Enterprise software vendors who are mostly left to figure it out on their own and Apple just claims that problems like this are the vendor's responsibility.  I'll take heat for these remarks certainly but from the trenches of IT, this is real experience.

Link to comment
  • 0

I had the same problem installing and make running the Workspace App on a MAC  with Catalina OS. The Access with the WEB-Version worked, but not with the Workspace App. There was the same error.

 

The solution was to install the attached certificates on the MAC and make them all "trusted" in the key-chain (in german its "Schlüsselbund") - (possible to download them also directly from Sectigo). After its it worked as wished.

May be it helps.

Best Daniel

cacertificate.zip

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...