Jump to content
Welcome to our new Citrix community!
  • 0

Server freeze/ hangs with elastic layer


Dominik Kurschat1709160009

Question

Hello,

we have a big problem since we updates the Applayering to 19.10. When a user with a Elastic layer is logged in on a server, the server freezes randomly. The server runs for hours, then crashes/freezes. It seems that the Windows desktop service crashes, remote registry and remote file services work, but you only see a grey surface on the machine. And you can‘t do anything. Its also impossible to log off users, you can only  make a reboot (from Vsphere).

A update to 19.11 doesn't fix the problem. Without Elastic Layers the server has no problems.

Servers are Windows 2012R2 with VDA 7.15 CU4.

Does anyone have an idea, what the problem is?

Link to comment

10 answers to this question

Recommended Posts

  • 0

To my knowledge, elastic layering isn't meant to work on Windows Server operating systems, only the desktop versions. I asked the same question due to getting errors when sysprep'ing a Server 2016 image for a Horizon pool with EL turned on, and I was told it was unsupported. Turned off EL, republished the layer, composed fine.

Link to comment
  • 0

Thanks for your answer.

I’m a little bit confused, I dont find anything in the Citrix documentation, that say’s elastic layering works only on Desktop Versions.

I only found this Statement in the documentation:

Elastic layers are delivered to users’ desktops when they log in. Elastic layers are based on user entitlements and can be used on both session hosts and standalone desktops published as layered Images. (https://docs.citrix.com/en-us/citrix-app-layering/4/layer/assign-elastic-layers.html)

 

In my opinion a session host is a server operating system.

And the elastic Layering works with ELM 1909, since we updated to 19.10, we got the Problems

Link to comment
  • 0

I don't think this is a server vs desktop issues because we are having the same issues on our desktops

we currently were in the middle of move users from unidesk2 to app layering, we are still running windows 7(i was suppose to be deploying windows 10 now)

I have had a ticket open with Citrix for 5 weeks

we were running 1908 and it was working fine, then i updated to 1910 and our test user are now locking up after 1-2day

support first gave us a patch for 1910 and then 1911, still the desktops lockup after 1-2 days.

the odd part is that RDP was still working for the desktops (we only use RPD for troubleshooting)

i was able to login to the desk and i notice that the device manage has no devices in it.

I even built a 2nd test elm with 1908 and tested to make sure it worked

then i update the elm to 1911 and the desktop lockup again.

I am stuck now and can't make any change to the environment without crashing alot of users

I am even considering rebuilding all the ELM layer (40+)

 

btw elastic layers are on and user layers are off

any test with elastic layers off work fine on 1911

 

Windows 7 x64

VMware Horizon View 7.1

Vcenter/ESXI 6.0U3

 

I was trying to finish migrating users from unidesk and update to window 10 and View 7.10 and Vcenter 6.5 updated by the end of the year

and that is not going to happen now.

Link to comment
  • 0

I'm using App Layering 19.11, Horizon 7.11, ESXi 6.7U2 + matching VCSA, and Win10 (all flavors) only work with quickprep, and I have to set the pool to delete on logoff; refresh doesn't work. Sysprep doesn't work at all with EL turned on. If you turn it off, the VMs will compose with sysprep just fine. It's been this way for many, many versions of App Layering.

 

I have a ticket open, and Citrix is moving very slowly with it. Took several days for them to analyze the ELM logs, bump it to someone, and I haven't received a reply back from the support agent to set up a time to work on this.

Link to comment
  • 0

We are using quickprep for desktops and the TEST pool i am running have the desktop set to never delete or refresh.

The desktop creates just fine and users are able to login. just over night if a user is logged in the desktop it lockup and stops working.

i have a 75% chance that i will lockup overnight and 100% that i will lockup over 2 day.

I usually just disconnected overnight.

 

I have published 2 template one before the update and one after

The one on 1911 crashes after 1 day and the one on 1908 has been running for 5 day without a issues.

 

just look at the device manager, that is just weird.

 

 

Devices.PNG

Link to comment
  • 0

the users desktop are the non-persistent pool with a user layer and they are set to delete when log off.

I have been testing at least 3 test a night for at least 5 weeks now. i created 3 test pool that replicated the issues 

the Test pool has that for trouble shooting. it still doesn't matter because the user gets a lock up on a 1911 image that has elastic layers.

the user just calls and says the mouse and keyboard are not working.

 

I started posting because the next steps are rebuilding layers on the ELM with 1908 and i really don't want to do that.

1911 with elastic layer on windows 7 is broken.

 

my upgrade path is 

move everyone to citrix (from unidesk)

update view to 7.10 or higher

update the template with 7.10 agent

start working on windows 10 1903 image

 

I am hoping that windows 10 doesn't have this issues

 

one idea is to use windows 10 1703 because it still might work with Horizon 7.1

 

 

Link to comment
  • 0

I would definitely move to Horizon 7.10 or 7.11. There is a new adaptive encoding scheme for the BLAST encoder in 7.11 that dramatically increase performance with audio/video, but has to be turned on via registry keys at the moment. 7.10 is an ESB version, so it's considered very stable. Also, check your VMware Tools version, as it can cause problems. 

 

Also, Windows 10 1903 or 1909 should be fine. 1909 doesn't fundamentally change/upgrade the OS, it simply enables some features that are already built into the 1903 codebase. I upgraded my OS layer from 1903 -> 1909 with no issues.

 

With ELM 19.11, ESXi 6.7U2, Horizon 7.11, and using quickprep, Elastic Layering and User Layers work perfectly as long as the pool is set to delete at logoff. I tested with 9 elastic layers, some quite large, along with the full user layer with Office 365 + OneDrive enabled, and it runs perfectly -- with those settings only.

 

Support for Win 10 1703 has ended, for all editions, so I wouldn't go that route. Win 7 is EOS in less than a month too, so might as well start with a current release of Win 10.

Link to comment
  • 0

ya but i am caught between a rock and a hard place

if i update view i need to deploy a new agent, vmware has said to update the agent asap

with the broken 1911 elm desktops would crash overnight (currently running a working image that was made on elm 1908)

and i can't test windows 10 1903+ because view 7.1 doesn't work with it.

 

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...