Jump to content
Welcome to our new Citrix community!
  • 0

[SOLVED] Citrix Workspace Linux App on Raspbian (Raspberry Pi 4 B with two Monitors) does not do Fullscreen over two monitors


Günter Waller

Question

Situation:

  • Hardware: Raspberry Pi 4B with 4GB Ram, Two Samsung FullHD 24" Monitors, connected via HDMI
  • Software: Raspbian GNU/Linux 10 (buster) ; Citrix Workspace app 1910 for Linux
  • The Citrix Workspace Linux App does start
  • The Citrix Workspace Linux App does fullscreen on one monitor only. If placed as a window on the left, the it fullscreens on the left monitor. If placed on the right, it fullscreens on the right.
  • The Citrix Workspace Linux App can be streched over the two monitors in window mode only

 

Symptom:

  • The Citrix Workspace Linux App does not extend to both the monitors, when swichted from window-mode to fullscreen-mode. The app was placed in the middle of the two monitors as adviced in the Manual (https://docs.citrix.com/en-us/citrix-workspace-app-for-linux/configure-xenapp.html#multi-monitor-layout-persistence , Chapter "Using Citrix Virtual desktops on dual monitor")

 

Whats the problem of the Symptom:

  • The full keyboard keys (especially the "Windows"-Key) only working in fullscreen mode.
Link to comment

12 answers to this question

Recommended Posts

  • 0

I had the same issue, and your fix worked! However, how do you make it always start like this? Now every time I start the session, it launches in one window, I have to go to Window mode move it in between screens and then go full screen every time, is there a way to change that?

  • Like 1
Link to comment
  • 1
On 12/9/2019 at 12:41 PM, Boby John1709155536 said:

What Path Have you installed your workspace app and what version are you running now ? 

do checkout https://support.citrix.com/article/CTX209485 as well 

 

Hi again,

 

Thanks for the hint to the other support article. That helped for further investigation. And first, here are the answers for your questions:

  • What Path Have you installed your workspace app and what version are you running now ? 

The installation is in :  /opt/Citrix/ICAClient

The start command is:  /opt/Citrix/ICAClient/selfservice --icaroot /opt/Citrix/ICAClient 

The version is:  icaclient_19.10.0.15_armhf.deb

The only way to configure the app is via "/home/pi/.profile". Changing the file, doing a restart of the linux and then the change is in place.

I tried the following entries:

  • export WFICA_OPTS="-span a" => No effect
  • export WFICA_OPTS="-span 0,1" => No effect
  • export WFICA_OPTS="-span 1,2" => No effect
  • export WFICA_OPTS="-span o" => No start of the app

The article stated, that the citrix app uses the _NET_WM_FULLSCREEN_MONITORS  message to request an appropriate window layout from the linux window manager. In Raspian the Windows Manager is OpenBox. OpenBox does not support the _NET_WM_FULLSCREEN_MONITORS message. And "-span o" does not work.

 

My conclusion is, that with OpenBox as linux Window Manager a fullscreen of the citrix app over two monitors is not possible.

  • Where to go next?

I change the Window Manager in my Raspian System from OpenBox to iceWM

  • Like 1
Link to comment
  • 1

[SOLVED] Changing the Raspbian Window Manager from OpenBox to iceWM enables fullscreen over the two monitors for the citrix app

 

And here are the steps I did to to change the window manager in Raspian:

  • 1) Install the window manager iceWM in raspbian

 suod apt-get install icewm

  • 2) Configure iceWM as window manager in raspbian

Edit "/etc/xdg/lxsession/LXDE/desktop.conf" and "/etc/xdg/lxsession/LXDE-pi/desktop.conf":

 

In both files earch for:

[Session]
window_manager=openbox-lxde-pi

and in both files change it to:

[Session]
window_manager=icewm
  • 3) Do a restart of Raspian, then the iceWM will be active as window manager

A comment to iceWM:

iceWM comes with a bloat load of additional applications and a second taskbar at the left bottom. I may investigate how to get rid of them or do a smaller installation.

  • Like 1
Link to comment
  • 1

[ADDITIONALS]
 

iceWM Customization

  • I searched for a iceWM Theme which aligns with the raspbian pixel destop apearance.

I found and installed: https://www.pling.com/p/1296339 on http://box-look.org 

  • I disabled the iceWM Taksbar:

1) In the iceWM preferences "/usr/share/icewm/preferences" set:

#  Show task bar
ShowTaskBar=0

2) Do a restart of Raspian, then the iceWM taskbar will not be shown

  • Like 1
Link to comment
  • 0

Hi @Boby John,

 

thank you replying to my problem and I'm happy to answer your questions:

  • Is it working on any other Receiver?  Have you got any other client , like Windows or MAC or any Linus FAT client to try ? 

Yes it is working in the proper fullscreen mode on two monitors and a laptop screen (so three monitors in all) with each of my windows Laptops in the following configurations:

  • Windwos 7 with all actuall updates and Citrix Windows Workspace App 19.4.1.4
  • Windwos 10 with all actuall updates and Citrix Windows Workspace App 19.4.1.4
  • Each Laptop is used with three screens (The Laptop screen, a vga connected Monitor, a usb vga graphics card with a connected monitor)

In the citrix reciever, which is running a remote Windows 7, there are all three monitors recognized.

  • Has the VDA got enough display Memory for both Monitors ?

I guess yes, because it is working with the Citrix Windows Workspace App, like I've answered in your  first question. And it works on Raspian in windows mode with the window streched over two monitors.

Link to comment
  • 0


1. At a command prompt, type:

/opt/Citrix/ICAClient/wfica -span h

A list of the numbers of the monitors currently connected to the user device is printed to stdout and wfica exits.

 

Also are you launching from the browser or the App itself ?
Does changing any of it make a difference ? 

 

Also the output of xprop -root | grep _NET_WM_FULLSCREEN_MONITORS

Link to comment
  • 0
1 hour ago, Boby John1709155536 said:


1. At a command prompt, type:

/opt/Citrix/ICAClient/wfica -span h

A list of the numbers of the monitors currently connected to the user device is printed to stdout and wfica exits.

 

Also are you launching from the browser or the App itself ?
Does changing any of it make a difference ? 

 

Also the output of xprop -root | grep _NET_WM_FULLSCREEN_MONITORS

 

Hi again @Boby John,

 

thanks for your quick response. Here are the results:

 

  • At a command prompt, type: /opt/Citrix/ICAClient/wfica -span h

This gives me an error: "Entry for ICA-File or appserv.ini not found".

 

  • Also are you launching from the browser or the App itself ? Does changing any of it make a difference ? 

I'm launching from the browser. Launching from the App itself does not work (It allways says "Wrong user name or password" and I copied & paste the password to make shure it is correct).

 

  • output of xprop -root | grep _NET_WM_FULLSCREEN_MONITORS

Nothing is displayed. Therefor I did: xprop -root | grep _NET_WM_ which gave:

 

_NET_SUPPORTED(ATOM) = _NET_SUPPORTING_WM_CHECK, _NET_WM_FULL_PLACEMENT, _NET_CURRENT_DESKTOP, _NET_NUMBER_OF_DESKTOPS, _NET_DESKTOP_GEOMETRY, _NET_DESKTOP_VIEWPORT, _NET_ACTIVE_WINDOW, _NET_WORKAREA, _NET_CLIENT_LIST, _NET_CLIENT_LIST_STACKING, _NET_DESKTOP_NAMES, _NET_CLOSE_WINDOW, _NET_DESKTOP_LAYOUT, _NET_SHOWING_DESKTOP, _NET_WM_NAME, _NET_WM_VISIBLE_NAME, _NET_WM_ICON_NAME, _NET_WM_VISIBLE_ICON_NAME, _NET_WM_DESKTOP, _NET_WM_STRUT, _NET_WM_STRUT_PARTIAL, _NET_WM_ICON, _NET_WM_ICON_GEOMETRY, _NET_WM_WINDOW_TYPE, _NET_WM_WINDOW_TYPE_DESKTOP, _NET_WM_WINDOW_TYPE_DOCK, _NET_WM_WINDOW_TYPE_TOOLBAR, _NET_WM_WINDOW_TYPE_MENU, _NET_WM_WINDOW_TYPE_UTILITY, _NET_WM_WINDOW_TYPE_SPLASH, _NET_WM_WINDOW_TYPE_DIALOG, _NET_WM_WINDOW_TYPE_NORMAL, _NET_WM_ALLOWED_ACTIONS, _NET_WM_WINDOW_OPACITY, _NET_WM_ACTION_MOVE, _NET_WM_ACTION_RESIZE, _NET_WM_ACTION_MINIMIZE, _NET_WM_ACTION_SHADE, _NET_WM_ACTION_MAXIMIZE_HORZ, _NET_WM_ACTION_MAXIMIZE_VERT, _NET_WM_ACTION_FULLSCREEN, _NET_WM_ACTION_CHANGE_DESKTOP, _NET_WM_ACTION_CLOSE, _NET_WM_ACTION_ABOVE, _NET_WM_ACTION_BELOW, _NET_WM_STATE, _NET_WM_STATE_MODAL, _NET_WM_STATE_MAXIMIZED_VERT, _NET_WM_STATE_MAXIMIZED_HORZ, _NET_WM_STATE_SHADED, _NET_WM_STATE_SKIP_TASKBAR, _NET_WM_STATE_SKIP_PAGER, _NET_WM_STATE_HIDDEN, _NET_WM_STATE_FULLSCREEN, _NET_WM_STATE_ABOVE, _NET_WM_STATE_BELOW, _NET_WM_STATE_DEMANDS_ATTENTION, _NET_MOVERESIZE_WINDOW, _NET_WM_MOVERESIZE, _NET_WM_USER_TIME, _NET_FRAME_EXTENTS, _NET_REQUEST_FRAME_EXTENTS, _NET_RESTACK_WINDOW, _NET_STARTUP_ID, _NET_WM_SYNC_REQUEST, _NET_WM_SYNC_REQUEST_COUNTER, _NET_WM_PID, _NET_WM_PING, _KDE_WM_CHANGE_STATE, _KDE_NET_WM_FRAME_STRUT, _KDE_NET_WM_WINDOW_TYPE_OVERRIDE, _OB_WM_ACTION_UNDECORATE, _OB_WM_STATE_UNDECORATED, _OPENBOX_PID, _OB_THEME, _OB_CONFIG_FILE, _OB_CONTROL, _OB_VERSION, _OB_APP_ROLE, _OB_APP_TITLE, _OB_APP_NAME, _OB_APP_CLASS, _OB_APP_GROUP_NAME, _OB_APP_GROUP_CLASS, _OB_APP_TYPE

 

Link to comment
  • 0
On 12/11/2019 at 7:07 PM, Günter Waller said:

[SOLVED] Changing the Raspbian Window Manager from OpenBox to iceWM enables fullscreen over the two monitors for the citrix app

 

And here are the steps I did to to change the window manager in Raspian:

  • 1) Install the window manager iceWM in raspbian

 suod apt-get install icewm

  • 2) Configure iceWM as window manager in raspbian

Edit "/etc/xdg/lxsession/LXDE/desktop.conf" and "/etc/xdg/lxsession/LXDE-pi/desktop.conf":

 

In both files earch for:


[Session]
window_manager=openbox-lxde-pi

and in both files change it to:


[Session]
window_manager=icewm
  • 3) Do a restart of Raspian, then the iceWM will be active as window manager

A comment to iceWM:

iceWM comes with a bloat load of additional applications and a second taskbar at the left bottom. I may investigate how to get rid of them or do a smaller installation.

Hi, i just bought the rapsberry pi 4. I am trying to install iceWM following this post but i doesn' work. I got stuck when i am trying to change "openbox" to icewm. The error message i get is in french "permission non accordée" i tried sudo, nothing work... Could you please help me ? Thank you.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...