Jump to content
Welcome to our new Citrix community!
  • 0

XenApp user always required to log in to O365


Andy White1709154166

Question

Hello,

 

We use XenApp 7.15 LTSR CU3 on Windows 2012R2.

 

Our Master image also includes Office 365.

 

We are trying to find out a solution to help users not have to login to O365 when they open Excel, Word etc everyday.  What happens is they log on to their XenApp desktop and open Excel for example and it will ask for their email address and password then use their mobile phone app to approve (MFA).  They will be fine if they stay logged in, but if thy log our and back in then they have to go though the signing process again.

 

How can we get round this?

 

Thanks

Link to comment

21 answers to this question

Recommended Posts

  • 0
7 hours ago, Paul Cross said:

Sounds like you haven't configured the token to roamed. Take a look at this - https://docs.microsoft.com/en-us/deployoffice/overview-of-shared-computer-activation-for-office-365-proplus. Note the section under Licensing token roaming.

 

I'd also be tempted to look at Carl's guide for configuring UPM - https://www.carlstalhood.com/citrix-profile-management

Agreed,
To elaborate on that a bit...

1st - Verify the Office installation is in Shared Computer Activation mode.  (Either via registry or GPO)

2nd - Have a look at where/if the activation token is being stored in the UPM user profile.  By default...it's in the following location...%localappdata%\Microsoft\Office\16.0\Licensing.

 

If that file isn't being maintained across connection attempts that will likely be the source of your issue.

Link to comment
  • 0

Various way of setting it up covered here - https://docs.microsoft.com/en-gb/DeployOffice/overview-of-shared-computer-activation-for-office-365-proplus?ui=en-US&rs=en-US&ad=US

 

Use regedit to add a string value of SharedComputerLicensing with a setting of 1 under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\ClickToRun\Configuration

Link to comment
  • 0

SharedComputerLicensing is already set to 1 under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\ClickToRun\Configuration

 

Updated the ADMX files and edited this below to a network folder share, but not working here.

Computer Configuration\Policies\Administrative Templates\Microsoft Office 2016 (Machine)\Licensing Settings.

 

I have this folder share but I need a folder for each user if I read that correctly, do I use %username% at the end?

 

image.thumb.png.070bdd1a2795e5c59f08d641be1b6fe4.png

 

Our Users are O365 E3 licensed btw.

 

Link to comment
  • 0
4 hours ago, Andy White1709154166 said:

SharedComputerLicensing is already set to 1 under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\ClickToRun\Configuration

 

Updated the ADMX files and edited this below to a network folder share, but not working here.

Computer Configuration\Policies\Administrative Templates\Microsoft Office 2016 (Machine)\Licensing Settings.

 

I have this folder share but I need a folder for each user if I read that correctly, do I use %username% at the end?

 

image.thumb.png.070bdd1a2795e5c59f08d641be1b6fe4.png

 

Our Users are O365 E3 licensed btw.

 

Yes, you'll need the %username% alias...I'd suggest using the path \\servername\UPM_Profile\%username%.  In your case that would be \\svr-dw01\UPM_Profile\%username%  

 

If you're using different versions of Windows between the sessions it's always a good idea to use another variable string to dictate the profile version.  

AKA  \\servername\UPM_Profile\%username%\!ctx_profilever!\

Link to comment
  • 0

Have you verified that UPM is loading back in the profile?  Check in C:\windows\system32\logfiles\UserProfileManager\servername_pm log file.

 

A screenshot of your GPO configuration for UPM would be helpful as well here.

 

In my setup I have UPM handling the profiles and did not specify a directory for the Shared Activation token (it defaults to AppData\Local\Microsoft\Office\16.0\Licensing...which if your UPM is configured to save Local AppData will automatically be loaded back in upon logoff/logon.

Link to comment
  • 0

Thanks for providing the sound solution regarding the Xenapp. Even I was also confronting with the same sort of consequences.I have another 
issue regarding MacOS Catalina.I have a Apple Macbook Air, and I am facing huge mailing consequences after upgrading it.I was using previously Microsoft Outlook
 as the Mail Client and I have observed that is responding slowly to macos Catalina.I had a conversation with the support about this issue and followed 
their guidelines discussed about the office 365 login .Please help us out to resolve this issue.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...