Jump to content
Welcome to our new Citrix community!
  • 0

GPU accelaration in Adobe products on VM Citrix Hypervisor


arturo Jarosz

Question

Hello,

In my company we use quite a lot of virtualization.

We have just setup one machine with a use of Citrix Hypervisor, to be used with Premiere PRO and Adobe Media Composer.

Operating system of this VM is Windows server 2016.

The grafic card we use on the host is :nvidia tesla p40 24gb.

I attached some screenshots.

Basically the card is not use by any of the two programs.

Premiere says sth like wrong driver which is not the case.

I tried nvidia tools nvsmi to check if the card is used but it says insufficient permissions.

Has any of you ever tried this kind of setup?
Anyone has an idea why it doesn't work?

Attached some screenshots.

Artur

 

GPU acceleration.JPG

nvidia1.JPG

nvidia2.JPG

premiere.JPG

Link to comment

14 answers to this question

Recommended Posts

  • 2

Hi,

 

Ask your admin to try to connect via XenCenter console to the VM and see if Adobe is using hardware renderer in console mode.

If it doesn't work in console you have to make sure Adobe is accepting your GPU. Google for cuda_supported_cards.txt or opencl_supported_cards.txt

If it works in console session your issue is with Microsoft RDP. In this case you have to ask your admin to enable RDP based graphics acceleration (Remote FX).

Anyhow if you are not using the Citrix protocol to access the remote session your question is better to be asked in a Microsoft forum.

 

Best regards,
Tim Wolf
Solution Architect
www.provectus.de

  • Like 2
Link to comment
  • 0

I'm not the person who set up this scenario, we have IT for that.

let me just try to explain our setup.

As I understood we don't use citrix session.

We basically have Xenserver which is hosting couple of VMs.

Among them, there is one with Adobe products.

We use RDP to connect to this VM and there we want to do some transcoding, editing and so on...

When I do benchmark test of the graphics cards, it seems according to some open source tools that graphic card is in use, also CUDA and OpenCL.

But the score in benchmark is very poor, and graphic card is used only in max 28%.

Here are couple of screenshots:fur_mark.thumb.JPG.f691aa5a6b39aa8dcd963e487520c0d8.JPGGeeks_3D.thumb.JPG.72df348e14cf395a1f3ad45a1b1ad57d.JPGGPU-Shark.thumb.JPG.3264856f57a94d86bc2a01e9e317f0c7.JPGGPU-Z.thumb.JPG.34abcf57a4e7e281296132ba2f64d481.JPG

Link to comment
  • 0

Run nvidia-smi on your XS to make sure it sees the P40 device properly; also, you will need to license from NVIDIA bot he XenServer install as well as any clients with one of the three licensing types, depending on your circumstances. Are you running passthrough, or what is the setup for the server and clients? Do you see the XS connected and consuming a license token if you go to the NVIDIA license manager?

 

=Tobias

Link to comment
  • 0

Hi Guys,

thank you all for the replies.

Quote

Run nvidia-smi on your XS

I did that and wrote the result in the original post, insufficient permission.

I also run adobe tools called GPUsniffer.exe and here it says clearly there is a card capable of doing CUDA and OpenCL but that the driver is old.

So first we gonna try to update the driver.

License is fine you can see the screenshot in first post.

Quote

Are you running passthrough, or what is the setup for the server and clients?

This I'm not sure, but I think it's passthrough. I will check that

Link to comment
  • 0
Quote

I did that and wrote the result in the original post, insufficient permission.

 

nvidia-smi should never fail on XS for permissions , because the CLI is always accessed as root. Did you try nvsmi or nvidia-smi

 

If you want to check the usage of your NVIDIA card inside the Windows VM , First navigate inside the folder for NVSMI , then try running it in a for loop like

 

for /l %g in () do @( nvidia-smi & timeout /t 2 ) 

 

This will show you the actual usage that NVIDIA trusts. 

 

 What about the Task-Manager - How much GPU usage does it show ? 

Link to comment
  • 0

I have tried again nvidia-smi. liek you said with timeout.

In background there was FurMark benchmark running. GPU-Z shows 17-20% usage of the GPU.

But nvidia-smi shows no usage. The result of benchmark is really poor, like from consumer graphic card.

I think because it's vGPU it doesn't show the usage there. Basically the tab with graphic card is not available.

nvsmi-10-sec.JPG

Link to comment
  • 0

Bobby John, it's Windows Server 2016. It's not activated, but I think for 180 days you can use it without any restriction, so it shouldn't affect the GPU?

With browser based benchmark GPU sharked showed maximum 23% of GPU and max 25% of GPU memory.

I'm still about to test the native app.

Thanks for your input.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...