Jump to content
Welcome to our new Citrix community!
  • 1

Published Application Outlook 2019 (connect to Exchange Online) with FSLogix not starting


Oliver Houmlchli

Question

Hello together

We have set up Outlook 2019 as a published application. Outlook is connected to Exchange Online. We use FSLogix for profile management and Outlook Cache mode. In the shared desktop you can start Outlook without problems and it works very well. But when I start the published Outlook, it hangs and the application doesn't open. It stops at "Is processed...". We have published other Office applications and they work very well, except Outlook. I can't find the error. Can anyone help me? Thank you very much for your support here in the forum.

 

Greetings

 

Oliver

Outlook.jpg

Link to comment

12 answers to this question

Recommended Posts

  • 0

Dear HoechliITCitrix,

 

We have the same issue.

In case we disable FSLogix for the user so we have local profile Outlook gets connected. In our case it is no activation issue. Instead Outlook 2019 can not connect to Microsoft as published Application. Via Desktop it is working without any problems.

 

Does anybody has an idea what may cause this issue?

 

Thanks.

 

Grettings

Mike

Link to comment
  • 0

Hello All,

 

My issue was similar but want to explain more in detail:

 

There are two scenarios - 

 

First scenario - 

 

1- While launching published desktop - Outlook works fine -It launches and load all the user's data 

 

Second scenario - 

 

1- While launching the published app it is stuck on "Loading profile " 

 

In order to fix this issue we tried a workaround first 

 

1- Try launching the session first in published desktop to make the session count =1

 

Now try launching the Outlook published app and it will work fine 

 

But if the same user comes next day with the session value - 0 or when he is starting his fresh session/new session it will again stuck on "Loading Profile" 

 

 

Environment-

 

VDA version -1912 cu2

Windows server version -2019

Outlook version -2019 

Profile type- FSlogix

 

Solution :

 

I did try fixing this issue by following the below keys :

 

 

Root: HKEY_LOCAL_MACHINE
Data type: REG_DWORD
Key: Software\Microsoft\Windows\windows Search\Preferences
Value name: PreventIndexingOutlook

 

 

HKCU\Software\Microsoft\Office\16.0\Common\Identity

value DisableADALatopWAMOverride

value data 1

 

11828970820_loadingprofile.JPG.94ea691d0a64706aed9c981757ef0c30.JPG

 

Note: If still it does not work then you may need to contact to MS .

 

Link to comment
  • 0

There is an official article from Citrix about the issue: https://support.citrix.com/article/CTX267071

 

Workarounds

Install Windows Server 2016 VDAs, as it does not have Web Account Manager, the component that is misbehaving.

Disabling Web Account Manager via registry has worked in few cases but is not recommended by Microsoft.

NOTE: This may not be supported by Microsoft because it causes other issues. Refrence:  https://docs.microsoft.com/en-us/office365/troubleshoot/administration/disabling-adal-wam-not-recommended

HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Common\Identity
“DisableADALatopWAMOverride”= dword:00000001

HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\16.0\Common\Identity
“DisableAADWAM”= dword:00000001

HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\16.0\Common\Identity
"DisableMSAWAM"= dword:00000001

Link to comment
  • 0

Hi folks.

 

Got the same issue at customer site. Downgrade to Server 2016 is in Spring 2022 not a possible solution for me and the customer.

Will try the workaround as also written in the referenced article. Or does anybody have a better solution for that?

We are not using FSLogix. We only using UPM from Citrix.

The Office 2016 installation we are currently running on the VDA is working fine but supports not new AddIns. ?

 

What about shared computer activation or something like that?

 

Best regards from Switzerland

Beat

Link to comment
  • 0

it seems that someone has found a workaround for this issue. running this in a logon script will solve it:

 

if (-not (Get-AppxPackage Microsoft.AAD.BrokerPlugin))
{ Add-AppxPackage -Register "$env:windir\SystemApps\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy\Appxmanifest.xml" -DisableDevelopmentMode -ForceApplicationShutdown }
Get-AppxPackage Microsoft.AAD.BrokerPlugin

 

credits go to Kasper Johansen (from World of EUC Slack) - i didnt try it myself, but since i never found it somewhere else, i thought its a good idea to share it here

Link to comment
  • 0

Update: Related article  CTX267071 Password Field Not Displayed for published Apps in Windows Server 2019 updated with new fix available in VDA 2206 and upcoming VDA LTSR 2203 CU1. Additional required Microsoft patches are documented and must be applied along with Citrix-side registry change

Solution

This issue is addressed by the new Shellbridge feature. To enable Shellbridge:

Install Citrix VDA such as version 2203 CU1 or version 2206.

Add the following registry details:

HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\Citrix Virtual Desktop Agent Name: Shellbridge Type: REG_DWORD Value: 1

Install the required updates to support the Shellbridge feature as follows:

image.thumb.png.46c91c7917b68a1c4b3c5498ab024074.png
Note:  Does not apply to Windows Server 2016. 
[LCM-7637]

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...