Jump to content
Welcome to our new Citrix community!
  • 3

Windows Server 2019 UAC issues


Martijn Kools

Question

Hello,


I'm currently testing Windows Server 2019 with XenApp 1909.

 

First thing I've noticed is when a user tries to change their language an UAC window pops up and he's asked to login with admin credentials. This is not the case with Windows Server 2016. I've enabled a policy to deny all UAC requests coming from a regular user but then they get the message: This app is blocked by your system administrator.

 

The UAC comes from: C:\Windows\System32\SystemSettingsAdminFlows.exe LanguagePackInstaller.

 

Another issue is the notification and action center, we have policies in place to disable it but it's being ignored in Windows Server 2019.

 

I wonder if anybody else had similar issue and knows a solution.

 

Thanks!

 

 

Link to comment

13 answers to this question

Recommended Posts

  • 0
14 hours ago, eferasi37 said:

We do face the same issue, i think this is by design, as the TS users should not mess around with the MUI, as well as the input KB layout and languages. 

The workaround is to use the GPO's to manage the KB preloads . 

Any other ideas ? 

 

 

Changing the language does work if you cancel the UAC prompts, so I don't think it is by design. On our old 2008R2 Citrix farm it worked without UAC prompts. We started building our new Citrix farm based on 2016 and I believe it also worked in that case. But because we required certain functionality that was only available in 2019  we switched to that version.

 

What I found out:

  • A user can change the language, he only needs to cancel all the UAC prompts (or you disable elevation with a policy which results in one message saying the application is blocked).
  • The number of UAC prompts increases with the number of languages that are installed. With 2 languages installed I get 2 UAC prompts, with 4 languages installed I get 8.
  • If you logon as an administrator and go to the page where you can change the languages and then try to change the language as a normal user no UAC prompt are displayed.

I think that when you go to the page to change the language something is being written to a file/registry where a normal user doesn't have write permissions.

 

I only haven't gotten around to test this further because we decided to set our default language to Dutch (most used) and instruct the users that want to change the language to just close the error message that says the application is blocked and just change the language after that. We are on a deadline because we need to move our Citrix farm to a new corporate domain before the end of the year, so other issues are more important at this moment.

 

Link to comment
  • 0

Hi Frank, 

We did face the same with the prompts, i think the user is not having the  rights to  run C:\Windows\System32\SystemSettingsAdminFlows.exe LanguagePackInstaller. ,  as we are a multinational company, we do have the challenge , and the only possible option right now  is to use the GPO and the keyboard preloads key to offer the multiple input langs which is also causing the issue that the KB  layout switching intermittently from one to another lang. 

it may worth  asking MS support for this "bug"

 

 

Link to comment
  • 0

I'm currently facing this issue as well in a new 2019 server image. I can't believe Microsoft programmed the mechanism so extremely sloppy whereas it used to be working perfect in our 2012R2 server image. 

 

Did anyone ever find a way to allow the user to add and choose keyboard layouts by himself without having to crawl through those popups ?

Link to comment
  • 0
38 minutes ago, Gian-Marco Venzin said:

Hi 

 

For us unsolved. Customer has Windows Server 2019 (OS BUILD 17763.1397).

 

I‘m going to update the vDisk an check it again.

 

I'm pretty sure it's solved in KB4570333, although it doesn't say anything in the changelog.

 

So you need to update to the latest patch Tuesday and you should be ok.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...