Jump to content
Welcome to our new Citrix community!
  • 1

Can't Update to 19.10.2.41 (1910.2)


Raymond DeGennaro

Question

I currently have Citrix Workspace 19.10.1.31 (1910) installed on macOS 10.15.1 (Catalina) and cannot update to the latest version (19.10.2.41 (1910.2) - Oct 17, 2019). If  I try to update using the auto updater, I get an unknown error.  If I try to download the installer from Cisco's site (https://www.citrix.com/downloads/workspace-app/mac/workspace-app-for-mac-latest.html), the EULA page cannot load, so I never get the download link.  I have tried Safari, Chrome & Firefox . When I click on the link, a DIV opens, and it looks like something starts to load, but then the DIV closes.

Link to comment

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...