Jump to content
Welcome to our new Citrix community!
  • 0

Outlook 2016 memory leak (I think) can WEM help?


Andy White1709154166

Question

Hello,

 

We use XenApp 7.15 LTSR CU3 on Windows 2012R2. We have been running Office 365 for some time and it's been working great until recently with Outlook as an App or Desktop.

 

For some reason a single user can take all 24GB of memory on the server and it will crash and unregister from Studio.  I've tried upgrading Office and downgrading with no luck.  I've sat with a user and they are doing nothing special and there are no plugins.

 

We use WEM too, can I use this to help stop the memory leak?

 

Thanks

Link to comment

4 answers to this question

Recommended Posts

  • 0

Hello,

 

We currently use XenApp 7.15 LTSR CU3 on VMware.  We use Office 365 and for some reason lately Outlook seems to randomly take all 24GB of memory on the VDA worker and unregister from Studio.

 

I've tried updating Outlook and downgrading without success.

 

As a temporary fix can WEM restrict how much memory Outlook uses for each user?  I've had a look and can't see how I do this.

 

Thanks

Link to comment
  • 0

Any chance you use Adobe Acrobat Reader for PDF's? We recently ran into an issue with Adobe that was not directly related but Citrix support had us upgrade our VDA's to 7.15 CU5 to address an issue with Outlook and Adobe Reader. The upgrade can be VDA only. You don't have to upgrade everything.

 

WEM can help with CPU and idle processes in memory, but can't fix a memory leak.

 

Take care,

Alain

Link to comment
  • 0

I'm having exactly the same issue. Started about 3 weeks ago and tried reverting our image back and it hasn't helped so suspecting profiles at this point but I don't want to reset 17,000 profiles (impacts about 12 out of 500 VDA's per day).  Any help would be appreciated!! Citrx support won't help us as this isn't "Citrix" and Microsoft won't look at dump files unless we pay for Premier support.  We've tried dumping just Outlook but the server crashes before the dump completes but I have full memory dumps.

 

We had a mishap with WEM about a week before this started where WEM had set its Infrastructure service to manual so unbeknownst to me WEM wasn't running after a reboot and our VDA's were running on offline cache until we rebooted them.  Thousands of desktop roaming profiles were overwritten by Citrix profiles as the UPM/CPM didn't have a configuration file and directed profiles to users AD settings.  I'm not sure if this had some indirect consequence to Citrix profiles now causing the issue I'm seeing today.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...