Jump to content
Welcome to our new Citrix community!
  • 0

Citrix studio crashing when loading in MMC after CU4 upgrade


Phil Neal

Question

I have recently upgraded Citrix 7.15 CU2 to CU4 and everything is fine except i am unable to load Citrix Studio via MMC console.  I can launch Citrix Studio via the standard launcher but as i want to put multiple farms in the same console i had been adding it via MMC to connect to the multiple farms, it worked fine on CU2 but since the upgrade i now get the below error:

 

Could not load file or assembly 'MmcSnapin, Version=7.15.4000.0, Culture=neutral, PublicKeyToken=70d1ad27b72179eb' or one of its dependencies. This assembly is built by a runtime newer than the currently loaded runtime and cannot be loaded.

 

 

Exception Type:

System.BadImageFormatException

 

Exeption stack trace:

 at System.Reflection.Assembly._nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection)
   at System.Reflection.Assembly.InternalLoad(AssemblyName assemblyRef, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection)
   at System.Reflection.Assembly.InternalLoad(String assemblyString, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection)
   at System.Activator.CreateInstance(String assemblyName, String typeName, Boolean ignoreCase, BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes, Evidence securityInfo, StackCrawlMark& stackMark)
   at System.Activator.CreateInstance(String assemblyName, String typeName)
   at System.AppDomain.CreateInstanceAndUnwrap(String assemblyName, String typeName)
   at Microsoft.ManagementConsole.Internal.SnapInClient.CreateSnapIn(String assemblyName, String typeName)
   at Microsoft.ManagementConsole.Internal.ClassLibraryServices.Microsoft.ManagementConsole.Internal.IClassLibraryServices.CreateSnapIn(String assemblyName, String typeName)
   at Microsoft.ManagementConsole.Executive.SnapInInitializationOperation.OnStart()
   at Microsoft.ManagementConsole.Executive.RunningOperationsTable.EnqueueOperation(Operation operation)
   at Microsoft.ManagementConsole.Executive.StandAloneComponentData..ctor(SnapInRegistrationInfo info, Int32 bookkeepingId)
   at Microsoft.ManagementConsole.Advanced.FrameworkSnapInFactory.Microsoft.ManagementConsole.Advanced.ISnapInFactory.CreateSnapIn(Int32 bookkeepingId, String snapInKey, Object& snapIn)

 

 

I have .Net 4.7.1 and C++ runtimes  2015-2019 (tried with 4.7.2 and still the same) and i am running PowerShell v5 running on Server 2008 R2.  Has anyone else had a similar issue?  any idea what version runtime it is expecting?

Link to comment

11 answers to this question

Recommended Posts

  • 0

Hi PhilNeal,

 

We have removed PS 2.0 dependency for Studio in 7.15 LTSR CU4 and the studio snap-in has to be launched in .NET 4.0 run time which is not the default one in W2K8R2. Though you could make use of environment variable to force the MMC .Net Runtime Version, I would recommend you to re-create the mmc snap-in in Win OS higher than W2K8R2 and manage the farms from there.

 

Regards,

S.Prasanna

Link to comment
  • 0

Hi Phil,

 

create powershell.exe.config where the powershell.exe executable is with below and try again. If it doesn't work, change the supported runtime as per the .NET framework version installed.

 

<?xml version="1.0"?>

<configuration>

<startup useLegacyV2RuntimeActivationPolicy="true">

<supportedRuntime version="v4.0.30319"/>

<supportedRuntime version="v2.0.50727"/>

</startup>

</configuration>

Link to comment
  • 0

Hi,

 

thanks for the replies, i tried using the activation_config file extension to force the version (there is even one for mmc in the install directory) but it did not seem to have any effect and still crashed when adding as a snapin via MMC.

 

i wouldnt have a copy of the dll which works and studio itself will open when using the standard msc just not as a snapin.  I tried to reinstall but everytime i tried to uninstall it kept flagging a missing MSI from the install director was missing despite it being there so was at a loss with that too.

 

i will go with putting it on a upgraded Windows servers since 2008 is EOL anyway and hope that resolves the issue.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...