Jump to content
Welcome to our new Citrix community!
  • 0

How do I enable audio in MyPCv2 session launched through Citrix Receiver?


Bob Hansen

Question

Hi I'm having a problem that's stumping our IT support staff. I use Citrix Receiver to log into my work workstation remotely from home. This works fine when I log into MyPC using my personal laptop. However when I log into MyPC using my personal desktop I don't have any sound. The sound icon in the lower right has a red X and says No Audio Output Device is installed.

I have tried selecting different audio output devices on my local desktop before logging in to MyPC but they all give the same result. My output sound options on my local desktop are

 

SPDIF-Out (Sound Blaster Z)
Headphones (SteelSeries Arctis 7 Game)
Speakers (Sound Blaster Z)
Realtek Digital Output (Realtek High Definition Audio)
Speakers (Steam Streaming Microphone)
iH282 (NVIDIA High Definition Audio)
HZ281H (NVIDIA High Definition Audio)
Realtek Digital Output(Optical) (Realtek High Definition Audio)
Headset Earphone (SteelSeries Arctis 7 Chat)
Speakers (Steam Streaming Speakers)

 

As far as I know all of these devices work on my local desktop. I can play audio through speakers, headsets, or even through my monitors using HDMI. But when I use a MyPC session there's no audio output. Like I said, if I use a different computer (laptop) to connect to MyPC then audio works just fine. So it must be something on the client end (my local desktop) that's special. Any ideas?

 

Local desktop:

Windows 10 Pro

Citrix Receiver (SelfService.exe) 4.11.0.36

 

MyPC workstation:

Windows 7 Enterprise SP1

Link to comment

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...