Jump to content
Welcome to our new Citrix community!
  • 0

App Layer removing software printers in compositing process


Question

Recommended Posts

  • 0
6 minutes ago, Rob Zylowski1709158051 said:

You should be able to add printer drivers in layers and as long as you add those layers to a published image the drivers should be included.  Adding a printer for a user cannot be included in a layer so the users will need to add the printer or you will need to add them using GPO's or third party printers applications.

This doesnt work for me... They show up as a ghost printer in devices and printers and dont show up at all in device manager. 

Link to comment
  • 0

Hi I tested with Foxit Pro installed in an app layer.  I published the app layer as part of the image.  I used App Layering 1910 with windows 10 1803 within PVS 1906.

 

Everything worked fine for me.  The foxit printer was there, I did not need to add it and i was able to print to it.

 

So it think this means its not a universal issue and you will need to work out with support what is happening in your case.

 

Rob

Link to comment
  • 0
17 hours ago, Rob Zylowski1709158051 said:

Hi I tested with Foxit Pro installed in an app layer.  I published the app layer as part of the image.  I used App Layering 1910 with windows 10 1803 within PVS 1906.

 

Everything worked fine for me.  The foxit printer was there, I did not need to add it and i was able to print to it.

 

So it think this means its not a universal issue and you will need to work out with support what is happening in your case.

 

Rob

Are you doing this with user layer enabled?

Link to comment
  • 0
Just now, Rob Zylowski1709158051 said:

Sounds like you have tried all permutations but i would certainly try creating and image with just one of your printer layers, the platform layer and the OS layer plus your user layer to see if the results are different.  We would be looking for some type of layer conflict there.

Yea i tried that as well. I also tried to install the software directly on the platform layer and using no app layers and the problem still persisted with all software printers.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...