Jump to content
Welcome to our new Citrix community!

Workspace Discovery Not Working through Netscaler


Rob Patterson1709152437

Recommended Posts

Similar issue to prior posting: https://discussions.citrix.com/topic/404149-workspace-discovery-not-working-through-netscaler/

 

Receiver discovery works internally, but not thru NetScaler (11.1 57.13.nc)..  Beacons are correct in Storefront (7.15 LTSR CU2; SF 3.12.2000.8) ; internal beacon not accessible externally.  External beacon:  https://remotetest.<domain>.org   No VDA on test machine, which is running Citrix Workspace 1812.  Session Policy does have Account Services address defined:  https://test-gateway.<domain>.org  Base URL of StoreFront is the same.

 

I enabled logging on Receiver on remote workstation.  Getting the following error logged:

 

Time: Wed Oct 30 16:26:34 2019 UTC
LocalTime: Wed Oct 30 11:26:34 2019
Type: Information
Module: Citrix Authentication Manager
Location: C:\Program Files (x86)\Citrix\ICA Client\AuthManager\AuthManSvr.exe
Version: 18.12.0.2 (Release)
Platform: Windows 10.0.9200 64-bit  SP Version: 0.0 SuiteMask: 256 ProductType: 1 IE: 11.1006.17134.0
Description: Citrix Authentication Manager terminating.

Time: Wed Oct 30 16:27:43 2019 UTC
LocalTime: Wed Oct 30 11:27:43 2019
Type: Warning
Module: Citrix Primary Authenticator
Location: C:\Program Files (x86)\Citrix\ICA Client\AuthManager\PrimaryAuthModule.exe
Version: 18.12.0.2 (Release)
Platform: Windows 10.0.9200 64-bit  SP Version: 0.0 SuiteMask: 256 ProductType: 1 IE: 11.1006.17134.0
Description: Unexpected protocol was received from the server.
Exception type: Protocol exception
Detail: Received an unexpected HTTP status 500 from the gateway
Context:
    During CAGLegacyAuthImpl::Authenticate to Gateway='https://remotetest.<domain>.org/'; current URL='https://remotetest.<domain>.org/cgi/login'


Time: Wed Oct 30 16:27:44 2019 UTC
LocalTime: Wed Oct 30 11:27:44 2019
Type: Warning
Module: Citrix Authentication Manager
Location: C:\PROGRAM FILES (X86)\CITRIX\ICA CLIENT\AUTHMANAGER\AUTHMANSVR.EXE
Version: 18.12.0.2 (Release)
Platform: Windows 10.0.9200 64-bit  SP Version: 0.0 SuiteMask: 256 ProductType: 1 IE: 11.1006.17134.0
Description: Unexpected protocol was received from the server.
Exception type: Protocol exception
Detail: A protocol exception occurred during logon
Context:
    During RetrieveOrCreateAgSessionForGateway gateway=GenericGateway(LegacyEEGateway(url=https://remotetest.<domain>.org/, auth type=Domain, ssl client auth=None))
    During CGatewayServiceTransaction::SendAndReceive gateway='GenericGateway(LegacyEEGateway(url=https://remotetest.<domain>.org/, auth type=Domain, ssl client auth=None))' path='/AGServices/discover'
    CAuthManImpl::RetrieveGatewayDiscoveryImpl gatewayInfo='LogonPointUrl='https://remotetest.<domain>.org/', Edition=Enterprise (2), AuthenticationType=Domain (2)'

 

Not quite sure where to look next.

 

Works internally, but not externally.  I also downloaded the Store Provisioning file and attempted remote connection again.  Basically same info in the Receiver log:

 

Time: Wed Oct 30 19:12:35 2019 UTC
LocalTime: Wed Oct 30 14:12:35 2019
Type: Warning
Module: Citrix Primary Authenticator
Location: C:\Program Files (x86)\Citrix\ICA Client\AuthManager\PrimaryAuthModule.exe
Version: 18.12.0.2 (Release)
Platform: Windows 10.0.9200 64-bit  SP Version: 0.0 SuiteMask: 256 ProductType: 1 IE: 11.1006.17134.0
Description: Unexpected protocol was received from the server.
Exception type: Protocol exception
Detail: Received an unexpected HTTP status 500 from the gateway
Context:
    During CAGLegacyAuthImpl::Authenticate to Gateway='https://remotetest.<domain>.org/'; current URL='https://remotetest.<domain>.org/cgi/login'


Time: Wed Oct 30 19:12:35 2019 UTC
LocalTime: Wed Oct 30 14:12:35 2019
Type: Warning
Module: Citrix Authentication Manager
Location: C:\PROGRAM FILES (X86)\CITRIX\ICA CLIENT\AUTHMANAGER\AUTHMANSVR.EXE
Version: 18.12.0.2 (Release)
Platform: Windows 10.0.9200 64-bit  SP Version: 0.0 SuiteMask: 256 ProductType: 1 IE: 11.1006.17134.0
Description: Unexpected protocol was received from the server.
Exception type: Protocol exception
Detail: A protocol exception occurred during logon
Context:
    During RetrieveOrCreateAgSessionForGateway gateway=GenericGateway(LegacyEEGateway(url=https://remotetest.<domain>.org/, auth type=Domain, ssl client auth=None))
    CAuthHttpRequestImpl::SendAndReceive

 

Some additional information . . . 

 

Wonder if this is related to the following post:

 - https://discussions.citrix.com/topic/376304-a-protocol-error-occured-while-communicating-with-the-authentication-service/

 

I checked the web.config in C:\inetpub\wwwroot\Citrix\Roaming and found there is  an entry under <add id=, as follows:

 

    <tokenManager>
      <services>
        <clear />
        <service id="c79b1bb1-16e5-4a2e-b4e9-de7af1074580" displayName="Roaming Consumer">
          <relyingParties signingId="_" defaultLifetime="01:00:00" maxLifetime="01:00:00">
            <clear />
          </relyingParties>
          <trustedIssuers decipherId="700d46a6-ae21-47b6-aafb-cdfadb29bcac">
            <clear />
            <add id="7650c9fb-7a27-411a-b9db-67e1484e0341" location="https://test-gateway.<domain>.org/Citrix/Authentication/auth/v1/token"
              verifyId="d59c8bb3-3dce-4880-bfa6-8b28d78ab2ca" />

          </trustedIssuers>
          <allowedAudiences>
            <add name="https-test-gateway.<domain>.org" audience="https://test-gateway.<domain>.org/" />
          </allowedAudiences>
        </service>
      </services>
    </tokenManager>

 

I have not yet had the opportunity to remove that entry and test.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...