Jump to content
Welcome to our new Citrix community!
  • 0

Youtube videos get choppy on nvidia T4, Citrix Virtual Apps and Desktops


Tomas Ferianc

Question

Hello

 

We're testing nvidia T4 Grid card with Citrix Virtual Desktops and Apps (version 7 1903).

Card offers 16GB video RAM, we set up 2 machines in catalogue, so that's 2x 8A in one profile.

When testing, WebGL and 3D apps like Autodesk portfolio seem to work very good.

What troubles us is YouTube videos.

They start playing smooth and then get quickly very choppy, like some buffer gets filled up or stuff like that.

I suspected Citrix policy settings, but we've set it up very same as on nvidia M10 system and problem remains.

 

Never had this issue with M10 (4x 8A in 4 profiles).

 

Any help please?

Link to comment

2 answers to this question

Recommended Posts

  • 0

there is a lot of optimization you can do to improve performance,

 

i used the very high experience template and tweaked even further for having a GPU

this is recommended by nvidia for improving the quality and user experience

       see, https://nvidia.custhelp.com/app/answers/detail/a_id/4131/~/optimal-citrix-graphics-policy-configuration-when-using-hdx-3d-pro-vda-and

 

I also set target framerate to 60fps

 

I also added additional options for quality

     https://www.citrix.com/blogs/2018/10/02/what-graphics-policies-do-i-need-and-when/

 

changed visual quality build to lossless

changed video codec to entire screen

 

I also turned on the options for h265

https://www.citrix.com/blogs/2018/01/07/h-265-encoding-now-available-for-xendesktop-using-nvidia-gpus/

 

Enable the Optimize for 3D graphics workload

Enable the Use hardware encoding for video codec

 

you also need to turn on the decoding on the clients, citrix receiver

https://docs.citrix.com/en-us/receiver/windows/current-release/improve/h-265-video-encoding.html

Open the Citrix Receiver Group Policy Object administrative template by running gpedit.msc.

Under the Computer Configuration node, go to Administrative Templates > Citrix Receiver > User Experience.

Select the H265 Decoding for graphics policy.

Select Enabled.

Click Apply and OK.

 

8A pofile does not use the quadro driver which is certified for autodesk. Quadro driver unlocks full capabilities of the card.

virtual pc and A profiles are meant for video playback.

 

you should review, https://images.nvidia.com/content/grid/pdf/161207-GRID-Packaging-and-Licensing-Guide.pdf

 

I strongly suggest you consider Q profiles for your autodesk workloads

 

note adding these settings will increase bandwidth of the citrix sessions

 

    

 

Link to comment
  • 0

also make sure you dont have set inside the browser to use software GPU.  this may be set using some of tweak tools out there automatically.

look, at

    https://support.microsoft.com/en-ca/help/2528233/how-to-enable-or-disable-software-rendering-in-internet-explorer

    https://www.recoverlostpassword.com/article/browser/how-to-turn-gpu-hardware-acceleration-on-or-off-in-chrome-internet-explorer-firefox.html

 

make sure software rendering is turned off so the videos use the gpu hardware for decoding of video inside the browser

   

        

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...