Jump to content
Welcome to our new Citrix community!
  • 0

Problem with IOS 13 and Citrix


Jeff Eddy

Question

I used the process in the link below:

https://help-docs.citrix.com/en-us/citrix-workspace-app-for-ios/settings-menu.html?_ga=2.88137436.611428106.1571535796-249009456.1571535796#browser

 

for the IOS 13 workaround.

When I get to stop 3 (tap on the filename that has been downloaded), all it does is show me the file name on the screen.

It still does not bring up Citrix and launch the sessiion.

 

Can anyone help? 

The screen below is what is shown when I tap on the file.

IMG_1260.PNG

Link to comment

6 answers to this question

Recommended Posts

  • 0

Unfortunately no, as of 10/21/19 Workspace does NOT work with iOS 13 either. I don’t know what is up with Citrix (or possibly Apple?) but the essential and mission critical tool keeps getting broken and there seems to be little interest from Citrix support in fixing it. 
 

On the iPad which many of our Doctors use to remotely access patient care apps, the .ica file is not associated with the Workspace iOS app. It was for a few days (here and there) but the update the week of 10/17 apparently removed the seemingly obvious and critical function so that, once again, there is no way to use Citrix on any iOS 13 iPad. Saving the ica file to the Files App and opening it from there no longer works. It was stated in one support doc that this change in iOS 13 only affected Safari, but it does exactly the same thing in Chrome or a couple other iOS Browsers I tried. And I’d like to point out that this multi step “download in safari -then open files - find your downloaded file and tap it -and then copy to workspace” was absolutely ridiculous - requiring this many steps to do what used to take only a tap (is it really so difficult just having an “Open” option next to the “Download” option?). 

 

If this is Apple’s fault my sincere apologies that I’m venting my extreme frustration at Citrix (after several Physicians venting their frustrations at me when they can’t remotely do things with a device that had been working, then wasnt, then was again, and with the most recent update is broken again!) tho Apple indicates it is a problem with Citrix Workspace not being updated for iOS 13 compatibility.
 

Does Citrix not want iPad users to be able to work? If so just say, that way we can find a product that is reliable and won’t break every other update and leave users in a major bind. PLEASE get this fixed IMMEDIATELY. Associate the .ica file with YOUR app so it will show up with the other apps that have no problem offering themselves as options to open an .ica file. Or even better, fix it work the way it used so the user just taps the icon and it opens the .ica file with the user never having to even know what any of that is and can get to work.

Seriously, what is the issue?

Link to comment
  • 0

Update as of November 30, 2019 

 

I updated my ipad to IOS 13 and citrix receiver stopped working. 

So I delete Citrix receiver, restart Ipad, download Citrix receiver and Citrix workspace app - it still did not work and work stuff does not open on Ipad.  

So I deleted Citrix receiver and Citrix workspace app again, restart ipad again and this time download only Citrix workspace app (did not download Citrix receiver this time) 

Then I signed into work website, it download ICA file, I clicked/tapped on ICA file and it open automatically in Citrix workspace and I was able to sign into work stuff, it worked this time. 

Also, if you are using Citrix X1 mouse (which I am), you have to pair it again for it to work. 

PS: I am not very technology inclined person, so some of the steps I mentioned above, may not be necessary, but this is how I made my work stuff open via Citrix workspace app on my Ipad. Cheers

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...