Jump to content
Welcome to our new Citrix community!
  • 1

Published apps not working on MacOS Catalina


Question

3 answers to this question

Recommended Posts

  • 0

I experience the exact same problem. Customers running apps from our Citrix-farm are not able to run applications from our web-portal after having upgraded to Mac OS X 10.15 Catalina even after updating to Citrix Workspace App 19.10.2 (700019.10.2.41).

 

I have done some testing myself and I am able to reproduce the problem. I am, however, able to start a published desktop. So far, I have not been able to find a workaround except from accessing applications published in our Citrix-farm from a virtual machine running Windows.

 

Some input would be appreciated before too many users with Mac report the same problem after having upgraded to Catalina...

Link to comment
  • 0

Having the same issue. Uninstalled and reinstalled but still the same issue. Odd this is that it was working for a bit, then it acted up. I reinstalled then started working, and now it gives the same error.

 

Another thing that is odd is that this is only affecting my 2018 MacBook Pro. My 2013 Mac Pro however was having the issue temporarily, but now it works fine.

 

Only thing I noticed different was that the Files and Folders section of the Security and Privacy menu of OS X has an entry for Citrix Viewer for my Documents. The MacBook Pro on the other hand does not. Seems like the program did not set that up during install.

Link to comment
  • 0

Check https://www.citrix.com/downloads/workspace-app/mac/workspace-app-for-mac-latest.html for latest Citrix Workspace app 1912 for Mac, Version: 19.12.0.23 (1912), released on December 10. This new version solved the problem. I no longer experience problems starting applications from Citrix Portal. 

 

I have just tested this on newly upgraded Mac OS Catalina 10.15.2. Previous version of Citrix Workspace App did not work any better on Apple's lates MacOS, so I guess it is the new Citrix Workspace App that will solve the problem in this thread on all supported platforms (Mac OS 10.13, 10.14, 10.15). 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...