Jump to content
Welcome to our new Citrix community!
  • 0

Any tricks to installing C++ 2005 Redistributable?


Darin McClain

Question

I need it for another application. Tried creating a new layer based on version 1 of my OS to get as clean of a machine as I can. Removed all existing C++ redistributables that I believe came from VMTools. Ran SFC /scannow and it repaired issues. Rebooted, but still won't install C++ 2005 redistributable. Hoping someone has dealt with this before and has a trick?

 

Darin

Capture.PNG

Link to comment

3 answers to this question

Recommended Posts

  • 0

I believe you are trying to do this in a version of the OS layer, correct? Yes, good. No, you should. Any components that are closely tied to the OS, should be installed in the OS layer to avoid possible conflicts, in the future.

I have not seen that error and cannot find any internal articles related to it. Try the below, maybe someone else has a suggestion, or you could open a case for assistance. 

https://answers.microsoft.com/en-us/windows/forum/windows8_1-windows_install/problem-installing-microsoft-visual-c-2005/76ebf4b0-49e5-449f-8f63-cdc570a077c1

 

https://support.acquiredigital.com/hc/en-us/articles/201648483-Error-1935-C-Redistributable

Link to comment
  • 0

I have recently had similar issues and I believe it is an elm issue. i can’t prove it or have it confirmed but caching has corrupted our OS layer. I turned off caching and had to go back to a may OS layer and update it with October updates. this did fix a few issues we had with the c++ redistribution. Upgrading our elm fixed a BSOD when we opened the c:\windows\system32\config folder. I still have two programs giving me problems when I try installing them in a packaging machine. I can’t prove what the problem is but I can prove exporting my current October OS and platform layers and import them into a ELM with 1905 (coincidentally a May ELM like going back to fix my OS layer) I am able to install, publish and have full functionality of the two applications. We can’t use that ELM because breaks windows defender. 
 

hope some of this helps or points you in a correct direction for troubleshooting 

Link to comment
  • 0

At first I was trying to do it in an app layer. Then I tried putting it in the OS layer, and it failed there too. But that's when i noticed the version I grabbed was slightly different than what was packaged with the installer. I had to grab a copy from temp files while it was attempting to install, then put that version in the OS layer. Once I got passed the first error, I ran into a second error with SQL Server Compact 4.0 SP1. I had to once again grab a copy of the installer from the temp files and put that in the OS layer as well. Once I got these two pre-reqs in the OS layer, it finally installed in an app layer successfully. Shew, what a mess!

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...