Jump to content
Welcome to our new Citrix community!
  • 0

CR01 - Citrix Receiver iOS app


Brian Mackowick

Question

Hello - I recently installed the CR01 app on a new iPad pro in order to be able to log in remotely. Worked great until the Apple software update to iOS 13. At this point, when attempting to log in, the Citrix website does not recognize the receiver app as being available on my iPad. 

 

Anyone else having this issue? I did find a random article online stating iOS 13 is not compatible with CR01. If that's the case, do we have any idea when it will be? Wish I had researched prior to upgrading.

 

Thanks for any help. 

Link to comment

4 answers to this question

Recommended Posts

  • 0

That's good to know, I had no idea. When I got set up my IT guys told me I needed to download Citrix Receiver, so I grabbed CR01 and it worked. I just assumed that's what I needed to use.

 

Will Citrix Workspace work similarly in that when I login through our VPN site it will automatically recognize Workspace and open up for me to login?

Link to comment
  • 0

Unfortunately no, as of 10/21/19 Workspace does NOT work with iOS 13 either. I don’t know what is up with Citrix (or possibly Apple?) but the essential and mission critical tool keeps getting broken and there seems to be little interest from Citrix support in fixing it. 
 

On the iPad which many of our Doctors use to remotely access patient care apps, the .ica file is not associated with the Workspace iOS app. It was for a few days here and there but the update the week of 10/17 apparently removed the seemingly obvious and critical function so that, once again, there is no way to use Citrix on any iOS 13 iPad. Saving the ica file to Files and opening it from there no longer works. It was stated in one support doc that this change in iOS 13 only affected Safari, but it does exactly the same thing in Chrome or a couple other iOS Browsers I tried. And I’d like to point out that this multi step “download in safari -then open files - find your downloaded file and tap it -and then copy to workspace” was absolutely ridiculous - requiring this many steps to do what used to take only a tap (is it really so difficult just having an “Open” option next to the “Download” option?). And if this is Apple’s fault my sincere apologies that I’m venting my extreme frustration at Citrix, tho Apple indicates it is a problem with Citrix Workspace not being updated for iOS 13 compatibility.
 

Does Citrix just not want iPad users to be able to work? If so just say, so we can find a product that is reliable and won’t break every other update and leave users in a major bind. 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...