Jump to content
Welcome to our new Citrix community!
  • 0

Encrypt Communication between Delivery Controller and Citrix Director


Jens Dellner

Question

Hi Guys,
I tried to encrypt the Data between the Citrix Monitor Service (Delivery Controller) and the Citrix Director (https://developer-docs.citrix.com/projects/monitor-service-odata-api/en/latest/).

 

There is already a SSL Certificate installed for the BrokerService which works well:
netsh http add sslcert ipport=0.0.0.0:443 certhash=<Thumpprint> appid=<BrokerServiceAppID>

 

So i thought i can use this certificate binding for the Monitor Service as well?

 

I already enabled Strong Encryption on both Delivery Controllers (https://support.citrix.com/article/CTX245765)

 

I removed the Monitor Service registration in the next step:
$serviceGroup = get-configregisteredserviceinstance -servicetype Monitor | Select -First 1 ServiceGroupUid
remove-configserviceGroup -ServiceGroupUid $serviceGroup.ServiceGroupUid

 

Then i tried to reconfigure the Monitor Service:
Citrix.Monitor.Exe -ConfigureFirewall -ODataPort 443 -RequireODataTls -ODataSdkPort 443 -RequireODataSdkTls

 

The first time there was an error message, that it is blocked by another process. So i registered the ConfigServiceInstance again, but also went back to a snapshot.

get-MonitorServiceInstance | register-ConfigServiceInstance
Get-ConfigRegisteredServiceInstance -ServiceType Config | Reset-MonitorServiceGroupMembership


Next I reconfigured the Monitor service first and there was no error. I removed the Monitor Service registration and registered the ConfigServiceInstance again on all Delivery Controllers.

 

The Citrix Monitor Service is running:

C:\Program Files\Citrix\Monitor\Service>Citrix.Monitor.exe /show
SDK Port: 80
Svc Port: 80
Key Port: 80
OData Port: 443
OData inter-service SDK Port: 443

 

But when i open https://{dc-host}/Citrix/Monitor/OData/v4/Data/Machines (for example), I only get a "Not found - HTTP Error 404".
http://{dc-host}/Citrix/Monitor/OData/v4/Data/Machines returns the OData. What am I doing wrong? Can someone give me an hint?

 

Citrix Virtual Apps and Desktops: 1909
OS: Windows Server 2016

 

I appreciate your help!

 

Best regards,
Jens

 

Link to comment

1 answer to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...