Jump to content
Welcome to our new Citrix community!
  • 1

Platform layer corrupts VDA installation


john smith1709152637

Question

Recommended Posts

  • 0

I've seen it repeatedly recently. Newly installed, fully patched Server 2019 used as OS layer with Applayering 19.10 tools and Citrix optimizer run on it. RDSH role installs in OS layer, but will not install in new platform layer; reboots to complete the install and says could not complete updates.

 

Documentation says "Although you can install the Remote Desktop Session Host role on the Platform layer with the VDA, the advantage of having the role in the OS layer is that it is updated as part of Windows."

 

BTW, after installing RDSH role in OS layer, no further Windows Updates are required.

 

As to why it is beneficial to put the RDSH role in a platform layer, it's useful for running Server VDI and a shared hosted desktop from the same OS layer, so the same list of apps.

Link to comment
  • 0

same here.
with Verison 19.10 the platform layer can not created. It end in a boot loop.

 

New OS Layer and an new install ELM 19.10

 

Server OS: 2012 R2

Provisioning: 7.15 LTSR 

 

Update: 
When you install the Terminal Role in OS Layer then Creation of Plattformlayer and Install VDA works. 

 

 

Link to comment
  • 0

ok i can now say, that when you Upgrade the Appliance to Version 19.10 (only the Appliance Upgrade - no Tools etc.)
after this you can't create a Fresh Plattformlayer from your OS Layer.

 

Workaround:

- Don't Upgrade the Appliance to 19.10.0.10

- Install the RDS Role in OS Layer and then create the Plattformlayer.

 

Link to comment
  • 0

Thanks.

My workaround for now is to install RDS in OS layer and then remove the time bomb license registry entry just before shutdown and finalizing the OS layer. This is because I have not joined the OS layer to the domain yet and I don't want to start the 120 day license countdown.

I have heard that this will be addressed in ELM 19.12.

 

 

Link to comment
  • 0
On 11/13/2019 at 10:11 AM, FBL Server said:

Thanks.

My workaround for now is to install RDS in OS layer and then remove the time bomb license registry entry just before shutdown and finalizing the OS layer. This is because I have not joined the OS layer to the domain yet and I don't want to start the 120 day license countdown.

I have heard that this will be addressed in ELM 19.12.

 

 

That is one way to handle it.  Another is right in the OS layer, just use a local policy to specify the license servers.  That is the way that I just did it and it worked like a charm.  I found this explained in the App Layering manual by Citrix.

 

Link to comment
  • 0
On 11/13/2019 at 3:11 PM, FBL Server said:

My workaround for now is to install RDS in OS layer and then remove the time bomb license registry entry just before shutdown and finalizing the OS layer. This is because I have not joined the OS layer to the domain yet and I don't want to start the 120 day license countdown.

I have heard that this will be addressed in ELM 19.12.

 

I can confirm it will be fixed in 1912 as Citrix support provided me with a private fix against 1911 and it fixes the problem.

Link to comment
  • 0

We have the same problem. Noticed it when installing the Feature Webdav Redirector. First tried installing it in an AppLayer which failed. Then tried installing it in a Platform Layer which also failed. Tried creating a new Platform layer with new VDA agent and noticed that the RDSH role also triggered the error.
When is the next version due to be released?

Link to comment
  • 0

I have had a ticket open on this issue.  We use vmware in our environment and Citrix support has directed me to this page. 

https://docs.citrix.com/en-us/citrix-app-layering/4/layer/prepare-os-for-layering/prepare-os-citrix-hypervisor-hyperv-vsphere.html

 

The section about "If using a Server OS, install the Remote Desktop Session Host feature" explains that we need to install RDS in the OS layer and not in the platform layer like we used to.  I don't know when that changed exactly since we had always had the RDS in the platform layer without issues previously.

 

Link to comment
  • 0
12 hours ago, Mark Larson1709153312 said:

I currently have ELM version 20.1.0.15 and I tried to install the RDSH role in a platform layer or trying to install VDA 1912 and both are failing to install in a new platform layer.  Is the fix mentioned above still coming?

 

The private fix to 19.11 and the released 20.1 both work absolutely fine in my testing, i.e. I can install RDSH role in a new platform layer on Server 2019 (using Citrix Hypervisor, but that's probably not relevant) whereas 19.10 and 19.11 did not work.

Link to comment
  • 0

I see this in the release notes of 2001:  "VDA installations no longer fail on a packaging machine. The issue where users saw repeated failures has been fixed. (UNI-76299)"

 

Is there anything else that you did other than update the ELM to get this to work?  My install of the 1912 VDA on server 2016 in a platform layer still fails on the install of the RDSH role.  Are they assuming that you have to install the RDSH role in the OS layer?  

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...