Jump to content
Welcome to our new Citrix community!
  • 0

Applayering PVS connector script issue


TRAVIS ADAMS

Question

I have a PVS connector script to perform some actions after the appliance generates the image. I've specified an account that has admin privileges on all servers in the PVS farm and the PVS console.

I'm having an issue in calling a get-wmiobject to another server to check for disk space to make sure the other servers in my farm have enough space to replicate the disk. When i run this i get the error:

Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED)) which in looking up states it could be a dcom error. I also tried a get-psdrive and i get a diffrent error: [STL-VGENPVST02] Connecting to remote server STL-VGENPVST02 failed with the following error message : WinRM cannot process the request. The following error with errorcode 0x8009030e occurred while using Kerberos authentication: A specified logon session does not exist. It may already have been terminated.

 

so my big question is, when applayering appliance kicks off a powershell script (it looks like it uses psremoting even though things state it comes through the applayering agent) does that session retain the permissions of the user launching it? in this case the service account that i specified in the connector setup page. 

Link to comment

3 answers to this question

Recommended Posts

  • 0

Powershell wont let you do anything over the network from that script without configuring kerberos constrained delegation to allow it.  What i do in those cases is write a flag file to a folder when the image is published.  Then i have a separate script running in a scheduler that reads the flag file which also has any of the data I want to pass to the other script and it can then use the network because its running locally on the PVS server so its not remote execution anymore.

 

Rob

Link to comment
  • 0

so this is in essence putting that box into a double hop scenario and doesn't exactly pass the creds all the way to the second hop. 

 

am i reading that correctly? so i can either do what you suggested, or find a way to pass the creds to the command i'm using (like invoke-command )? 

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...