Jump to content
Welcome to our new Citrix community!
  • 0

ELM 19.8.0.11 on Azure - error: "The error from Azure is:unable to get local issuer certificate"


Sergiu-Konrad Kork

Question

Running ELM as an Azure imported VM for almost a year now. It is servicing an Azure based Citrix deployment, for MCS catalogs.

 

This morning I suddenly can't do any operations anymore, getting the error "unable to get local issuer certificate". Also getting the same error when running the test on the connectors.

 

 

What i did so far:

- rebooted several times, no joy

- generated a new certificate (&reboot), no joy

- tried to create new connectors, no joy (even used different Azure storage)

- checked the Azure storage blob's certificate, it is OK. I can actually use the same storage to a different ELM, all works OK.

 

 

A little background: I have 2 ELM appliances in the environment, each using 2 Azure storage blobs. The other one works fine.

- if i use the storages from the working ELM to create a new connector for faulty ELM, it fails with the above error

- if i use the storages from the faulty ELM to create a new connector for working ELM, is is successful

- connector tests from working ELM are successful

- connector tests for faulty ELM fail

- this morning both appliances have had the same certificate on them (not "similar" - the same, with the exact same hash). During today i generated a new one on the faulty ELM, to no avail.

 

 

 

Any ideas ? :)

 

Link to comment

1 answer to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...