Jump to content
Welcome to our new Citrix community!
  • 0

Management Agent not installed Ubuntu Server 19.04


Ryan Hutton

Question

Hello All,

 

I am running XenCenter 8 and I have a Ubuntu Server 19.04 VM running. I have installed the Citrix VM Tools and it seemed to install correctly. Only problem is it is still saying "Management Agent not installed." Not sure how to fix this. I followed the instructions from here: https://docs.citrix.com/en-us/xencenter/current-release/vms-installtools.html?utm_campaign=8_0_0_7086&utm_medium=ui_link&utm_source=xencenter

 

Thank you.

Link to comment

1 answer to this question

Recommended Posts

  • 0

Hey Ryan & welcome to the forums!

Sorry, a bit late, but I was just dealing with similar issues in my environment and stumbled over your thread here. May it help someone else to solve that.

If the guest OS is mentioning missing management tools after the switch to HVM, it might be because some platform settings are missing due to an older template being used while setting up the guest OS initially. Check these:

xe vm-param-get uuid=<vm-uuid> param-name=platform

In my case (Ubuntu 18.04 built loooong time ago) it was one or some of the following:

xe vm-param-set uuid=<vm-uuid> platform:nx=true
xe vm-param-set uuid=<vm-uuid> platform:viridian=false
xe vm-param-set uuid=<vm-uuid> platform:acpi=1
xe vm-param-set uuid=<vm-uuid> platform:device_id=0001

Bfn, Konrad

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...