Jump to content
Welcome to our new Citrix community!
  • 0

Windows Server - Upgrading XenTools leads to serious instability of the guest


David Reade

Question

I have a handful of Windows Server 2012 R2 guests running different versions of XenTools, as follows:

Guest 1 - Tools 7.1.1305 - Active Directory (PDC), DHCP, DNS
Guest 2 - Tools 7.1.950  - Exchange Server 2013
Guest 3 - Tools 7.1.814  - File/Print Services
Guest 4 - Tools 7.1.1305 - SQL Server

All guests are running the same version of anti-virus; ESET File Security for Windows Server v7.

 

I have previously tried to upgrade all guests but struggled and therefore given up on anymore attempts, thus why only two guests are running the same version, but even then those guests still struggled during the upgrade process and yet I have no idea why.

 

The upgrade process I executed was to simply run the latest Tools MSI installer, allow it to complete and then reboot when prompted. Upon booting, at the "Please wait..." screen before the CTRL+ALT+DEL prompt, the guest would take several minutes to get to the next screen during which the guest CPU, Memory, Disk and Network Usage is sky-high and the overall host performance is very poor. I would try to login but the guest would just hang on the next screen and never actually login. Luckily I took a snapshot before the upgrade and would have to revert to the snapshot, but this should not be happening and I should just be able to upgrade the tools without an issue.

 

I suspect there is something running on the server, or trying to run and getting stuck in a loop, but since I am reverting the guest and I cannot login to the guest, I cannot check the Event Log and so I never know what's causing the guest not to upgrade the tools.

 

Is there a specific procedure I should be following, especially where Windows Server guests are involved and those guests are running network-dependant services such as Exchange Server?

 

Do I need to remove the old tools first?

 

Do I need to stop specific services and disable them so they do not try to start at boot-up?

 

Thanks in advance.

Link to comment

4 answers to this question

Recommended Posts

  • 0

That's the version I'm trying to install. I might have to remove the AV instead as I'm sure I've tried disabling the AV before, plus the Exchange Server is actually running a different version - that which is specific to Exchange Server.

 

Is there any reason why the guest would behave in this way though? Seems odd that AV would make it behave like this.

Link to comment
  • 0

The xenvif driver 8.2.1.170 (included in installer 7.1.0.1305) can start to take longer to allocate memory in some situations, which triggers a slowdown in network traffic. This issue seems to affect long running or busy Exchange servers more than other high network traffic usages. Its possible the AV software is also effected here, especially if its intercepting packets for inspection.

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...