Jump to content
Welcome to our new Citrix community!

StoreFront 1909 - Installer problems... 'Set-DSNewClusterEnvironment' on Server 2019


Jeremy Holt1709157952

Recommended Posts

Trying to install StoreFront 1909 on Server 2019 and after install of storefront it errors attempting to create the first store.

 

See attached image for error.

 

Also got the error attempting to installed the 1906 version on Server 2019.

 

Tried both the stand alone installer as well as the Virtual Apps and Desktops ISO.

 

To confirm... this is a new windows 2019 server with static IP, joined to the domain, and windows updates applied only.  no AV, or anything else.

 

Citrix Support doesn't seem to have any ideas what the issue is as well.

 

Anyone else experience this issue or have some resolution options?

Storefront error.png

Link to comment
Share on other sites

  • 3 weeks later...

Hi jholt273

The Storefront console shows the correct version, however Control Panel > Programs and Features shows the 1811 version.  I'm not sure if they changed something in the installers, but I'm not sure this is acceptable.

Can you send me a screen shot of the control panel?  Does it reference CVAD anywhere or is there a single entry mentioning only StoreFront?

 

Also how was the StoreFront provisioned?  PowerShell scripted install or just using the admin console/installer?  

Regards Mark

Link to comment
Share on other sites

I'm not in front of the client environment at the moment, however it does not reference CVAD anywhere, and there is a single entry for Storefront.

 

When installing 1909 on the server 2019 (not an upgrade) nothing shows up in control panel.

 

Storefront was installed directly from the installer.  We tried the stand alone StoreFront installer as well as from the CVAD iso.

Link to comment
Share on other sites

When installing 1909 on the server 2019 (not an upgrade) nothing shows up in control panel.

Is the StoreFront on an eSXI VM by any chance?  If so can you tell me the VMWare tools version installed please?  Other customers have reported this exact same issue and it is only on certain VMWare tools versions such as 10.3.xx.  Using 10.2.0 or upgrading the tools to later versions such as 11.xx resolved the issue.  You may need to reinstall StoreFront once the tools version has changed.

 

Other customers also experience a more serious upgrade failure using the CVAD metainstaller if 10.3.xx was installed so please stick to using the standalone StoreFront installer.

 

Regards Mark

  • Like 2
Link to comment
Share on other sites

  • 4 weeks later...

Ran into this exact issue as well on ESX  with clean installs of W2019 and 1909. Only after updating the VMtools to 11.x SF 1909 finally installed - so Mark many thanks for the tip but its seriously not good that Citrix has not fixed this issue that has existed since 1906 or clearly state that ESX vmware tools must be version 11.x for the  install to work.

Link to comment
Share on other sites

  • 1 month later...

Hi StoreFront admins

 

I would urge all StoreFront admins who are running VMs on ESXI to move to the latest LTSR release as it is supported as part of our LTSR program with cumulative updates and bug fixes.  It also contains every feature in StoreFront to date.  It also includes some changes to the way the StoreFront metainstaller handles requests for reboots after upgrade.  These changes were made to tackle this exact issue of upgrade failure when the StoreFront VM is using VMware tools 10.3.x.  The issue is therefore fixed in 1912 LTSR.  

If using VMware tools 10.3.x

  • Backup VM snapshots should be taken before upgrading any Citrix component including StoreFront.
  • It should be possible to upgrade from 1903 or earlier to 1912 without encountering the problem mentioned here.
  • If you have already upgraded from 1903 --> 1906 or 1903 --> 1909 then you will need to revert to pre upgrade backups before attempting to upgrade to 1912 LTSR.
  • The 1912 LTSR fix cannot restore a StoreFront server from a broken state caused by VMware tools 10.3.x
  • Attempting to uninstall StoreFront after the issue has already occurred can be very problematic and is not recommended. 
  • The safest solution is to revert to the server state before upgrading from 1903 to any higher version.
  • Upgrading to VMTools 11.x is also an option to prevent the issue occurring with 1906 or 1909 but it is recommended you upgrade to 1912 LTSR instead.  

Regards Mark 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...