Jump to content
Welcome to our new Citrix community!
  • 0

VDA ignores /Logpath if "/NOREBOOT" is not included in the command line.


Eddie Santana

Question

I am rolling out WorkStationCore VDA for Remote PC Access. The silent deployment is will log locally. However if I include the '/NOREBOOT" , the logs go to the specified location. 

The detail in the local XenDesktop+Installation.log file looks correct. 

I was able to reproduce this on 3 computers so far

 

Here is the install cmd line

VDAWorkstationCoreSetup_1909.exe /QUIET /ENABLE_HDX_PORTS /CONTROLLERS "blah1.blah.com blah2.blah.com blah3.blah.com" /logpath "\\server1\Logs\CitrixVDA\%computername%"

Note: The logs DO go to this location IF the /NOREBOOT is specified.  

 

 

Here is the output from log:
04:40:33.8849       : XenDesktopSetup:Component 'Citrix Authentication Identity Assertion VDA Plug-in' and dependencies instantiated.
04:40:33.8859       : XenDesktopSetup:Component 'Citrix Universal Print Client' and dependencies instantiated.
04:40:33.8859       : XenDesktopSetup:Component 'Citrix Disconnect Button' and dependencies instantiated.
04:40:33.8969       : XenDesktopSetup:Commandline arguments: /QUIET, /ENABLE_HDX_PORTS, /CONTROLLERS,blah1.blah.com blah2.blah.com blah3.blah.com, /logpath, \\####\Logs\CitrixVDA\#######
04:40:33.9657       : XenDesktopSetup:Checking for Virtual Machine environment and caching the results...

-----------------------------------------

04:40:34.0076       : XenDesktopSetup:MetaInstaller Version: 7.23.0.48
04:40:34.0076       : XenDesktopSetup:Product Type: XenDesktop
04:40:34.0076       : XenDesktopSetup:Operating System: Windows10
04:40:34.0086       : XenDesktopSetup:User: NT AUTHORITY\SYSTEM
04:40:34.0086       : XenDesktopSetup:Current User Preferences follows state: after-process-cmdline
04:40:34.0136       : XenDesktopSetup:ShowUI = False
NoReboot = False
NoPrerequisites = False
UIMode = Quiet
LogPath = \\####\Logs\CitrixVDA\#######
VerboseLog = False
WorkingDirectory = C:\WINDOWS\TEMP\rbt_6786d854-1c25-47cd-a404-###########
InstallDirectory = C:\Program Files\Citrix
CDRoot = 

...................

 

The above looks correct... but logs end up local on the machine. 

Link to comment

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...