Jump to content
Welcome to our new Citrix community!
  • 0

Generic USB Scanner driver install issue


Andrew Gresbach1709152664

Question

We have a small mail center environment that uses Windows Embedded thin clients with Canon DR-G1130 scanners plugged into them via USB.   Users connect to their MCS desktops and we have to use generic USB passthrough so that it can be used with the needed application.   I am running into 2 issues i'm hoping someone can help with (i opened a case for this as well but hoping someone here might have an idea too):

 

1.  I cannot seem to figure out how to configure this device to pass through generic by default (passes through optimized and i have to manually change to generic via Citrix toolbar)

 

2.  The bigger issue is after I toggle it to pass through as generic it passes through and Windows 10 (1903) says the device is ready but Device Manager shows as no driver

image.thumb.png.9e2ce3f97b7a4b83ef689ac2bd671049.png

The only way that i can get it to work is if i go to Update Driver and use the option to show All Devices (common devices do not work), scroll down to CANON and only then does the driver show up (this driver is baked into the published image already).   

image.thumb.png.b7e645a5512848f020b6c99a0aced71f.png

 

After this, everything works great until the user reboots in which we need to do this all over again.

 

This works fine on our Windows 7 image (switching to generic it installs fine on its own) so not sure what is going on

 

any help would be awesome!  thank you

Link to comment

2 answers to this question

Recommended Posts

  • 0

I was able to get the forced generic redirection working w/ supports help by setting local group policy for the receiver  on the thin client.  Now i'm stuck w/ Windows 10 detecting the proper drivers (which are installed in the image) .   Support is digging for me but i tried calling Canon as well and they shut down immediately when i said it was in a Citrix environment and said they absolutely cannot help me because they are not trained for that nor support it.   They did say this model is fully supported w/ Windows 10 though so i'm hoping someone on the Citrix end can help so we can continue this migration

Link to comment
  • 0

I  figured out the canon scanner driver issue.....found out that it worked fine if i manually installed it in the published image but never if the app layer was selected in the published image template so must be some issue w/ a conflict during the desktop publishing .   I tried installing it in the platform layer and that seems to be working.  I'd prefer to not clutter the platform layer but if it works i'll run with it for now

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...