Jump to content
Welcome to our new Citrix community!

Exchange SSMTP load balancing


Recommended Posts

We are load balancing SMTP traffic via Netscalers, however, email flow breaks if we choose SSL_TCP protocol. It works fine if we use TCP on 587...

 

From our Wireshark traces we found that SSL handshake packet from the client-side to Netscaler, when we try to send email using the below script.  SMTP server mentioned in the below script is Netscaler VIP configured on SSL_TCP Protocol, it just errors out with “ Operation timed out” .  If we use a different VIP configured on plain TCP protocol then it works fine

 

At this moment we are not sure , why the traffic is not evening hitting Netcaler , not sure if this is a problem with the script or something else.   Please suggest 

 

$anonUsername = "*********"
$anonPassword = ConvertTo-SecureString -String "**********" -AsPlainText -Force
$anonCredentials = New-Object System.Management.Automation.PSCredential($anonUsername,$anonPassword)
$From = "user123@abcd.com"
$To = "user123@abcd.com"
$Subject = "Here's the Email Subject"
$Body = "This is what I want to say"
$SMTPServer = "10.36.117.244"
$SMTPPort = "587"
Send-MailMessage -From $From -to $To -Subject $Subject -Body $Body -SmtpServer $SMTPServer -port $SMTPPort -Credential $anonCredentials 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...