Jump to content
Welcome to our new Citrix community!
  • 0

Chromium Based Edge browser doesn't launch w/VDA installed

Eric Gilliland


Hey all,


As you may know, Microsoft is re-writing Edge to be Chromium based and is currently in beta testing - https://www.microsoftedgeinsider.com/en-us/. I've installed it on some 2016/2019 VDAs, and I can't seem to be able to run it. When it launches, a solid white window hangs indefinitely with many event log application crash errors every few seconds (pasted below). I've peeled back all GPOs to see if there isn't any setting there. It also launches fine when connected to the console, but the issues surfaces when opening the browser from a RDP or ICA session. I've tried both 7.15 LTSR and CVAD 1906 with the same result.


When a VDA is uninstalled, the browser launches fine over RDP.  Anyony have any ideas on this?


Faulting application name: msedge.exe, version:, time stamp: 0x5d79605a
Faulting module name: ntdll.dll, version: 10.0.17763.592, time stamp: 0x0f1b8afd
Exception code: 0xc0000005
Fault offset: 0x000000000000d030
Faulting process id: 0x54c
Faulting application start time: 0x01d56c91f476bfed
Faulting application path: C:\Program Files (x86)\Microsoft\Edge Beta\Application\msedge.exe
Faulting module path: C:\Windows\SYSTEM32\ntdll.dll
Report Id: eda00e21-1a29-435e-937c-85c6f86e78e7
Faulting package full name: 
Faulting package-relative application ID: 

Link to comment

9 answers to this question

Recommended Posts

  • 3
2 hours ago, Kasper Johansen1709159522 said:

Thank you very much, Kasper. The solution was to add msedge.exe into this reg string 


From linked thread:

Based on what your seeing, I turned off the Citrix API hooks for Edge.


Key: HKLM\SYSTEM\CurrentControlSet\services\CtxUvi 
Value Name: UviProcessExcludes 
Type: REG_SZ 
Value: badapp1.exe;badlongname.ex;badapp2.exe 

  • Like 3
Link to comment
  • 0

Hey there, i have done that on a windows 2019 server vdi setup and my Edge (Chromium) starts but dont output any sound and edge is not shown in the sound mixer application but on a edge tab which should playing sound it got the soundsymbol.


Does the disabled API Hook hack for Edge diesable redirect sound to citrix (vda or whatever)?


my setup

ctx apps and desktop 1912 with pvs / no pvdisk

OS -> MS Server 2019 standard latest patches

MS Edge Chromium V. 80.0.361.66


Does Sound work for you guys? any Ideas are welcome i dont want to switch to another Browser but we need Sound in it sometimes and IE is not really a alternate but the Sound is working on that browser.




Link to comment
  • 0



There is a known issue with the AudioSandBox feature, in both Google Chrome and Edge. In terminal server based session you need to disable it.

  1. You can disable it via an executable parameter: msedge.exe --disable-features=AudioServiceSandbox (Useful for a quick and dirty fix)
  2. You can use a registry fix - 


I'll recommend the registry fix, as the parameter is only used when Edge is started via a shortcut, and not when the user clicks on a link in a mail.

You can find more information about the AudioSandBox feature here:


Link to comment
  • 0
31 minutes ago, Sander de Valk said:

This isn't working for me.


Virtual Apps 1912

Windows Server 2019 build 17763.1039

MS Edge Enterprise 80.0.361.69

Chrome Enterprise 79.0.3945.130 (Officiële build) (64-bits)


Edge and Chrome no sound anymore, only IE11 works.


Any new updates regarding this issue? 

Found the solution https://chrome.google.com/webstore/detail/browser-redirection-exten/hdppkjifljbdpckfajcmlblbchhledln

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...