Jump to content
Welcome to our new Citrix community!
  • 0

MCS fails to update


Christian Arnold

Question

Hi guys,

 

I upgraded Virtual Apps from 1903 to 1906.2 (that went well) and then tried updating the master image. While the setup process didn't show me any errors, I guess while updating the VDA something went wrong. When I try to update the image from my master vm, I get this error:

 

Stack Trace:
   bei Citrix.Orchestration.Base.PowerShellSdk.ProvisioningSchemeService.BackgroundTasks.ProvisioningSchemeTask.ThrowOnTerminatingError(SdkProvisioningSchemeAction sdkProvisioningSchemeAction)
   bei Citrix.Orchestration.Base.PowerShellSdk.ProvisioningSchemeService.BackgroundTasks.ProvisioningSchemeTask.WaitForProvisioningSchemeActionCompletion(Guid taskId, Action`1 actionResultsObtained)
   bei Citrix.Orchestration.Base.PowerShellSdk.ProvisioningSchemeService.BackgroundTasks.PublishProvisioningSchemeImageTask.RunTask()
   bei Citrix.Orchestration.Base.PowerShellSdk.BackgroundTaskService.BackgroundTask.Task.Run()

DesktopStudio_ErrorId : ProvisioningTaskError
ErrorCategory : NotSpecified
ErrorID : WriteBackCacheDriverIssue
TaskErrorInformation : Terminated
InternalErrorMessage : A problem was detected during the Write Back Cache compatibility check. The issue was: The Write Back Cache driver was not found.

 

In the Known Issues it is said that new MCSIO drivers will be installed even if they weren't installed before. Is this the problem? Do I have to roll back to the 1903 snapshot of my VDA and keep it there? I can't find anything more on PVS-4151

 

Best,

Chris

Link to comment

8 answers to this question

Recommended Posts

  • 0

nice to hear..

I dont have any issues with that option. Here is my full cmd, it is for MCS and image

"D:\x64\XenDesktop Setup\XenDesktopVdaSetup.exe" /Components VDA /controllers "blablabla" /Exclude "Smart Tools Agent","Citrix Supportability Tools","Citrix Universal Print Client","Citrix Personalization for App-V - VDA","Citrix Telemetry Service","Personal vDisk","AppDisks VDA Plug-in","Citrix Files for Windows","Citrix Files for Outlook" /install_mcsio_driver /enable_framehawk_port /enable_hdx_ports /enable_hdx_udp_ports /enable_real_time_transport /enable_remote_assistance /disableexperiencemetrics /nodesktopexperience /virtualmachine /mastermcsimage /optimize /quiet

 

maybe may help

bye

Link to comment
  • 0
On 9/18/2019 at 2:03 PM, Christian Arnold said:

Sadly, not all command line options work, /install_mcsio_driver is one of them. But removing VDA with the VDACleanupUtility and reinstalling it with the manually selected MCS IO Driver worked. So thanks for the Cleanup Utility tipp!

 

Did you ever get this working? I have ".../install_mcsio_driver /mastermcsimage /optimize /quiet..."  in my commandline and the MCS optimization isn't working for me either.

Link to comment
  • 0
35 minutes ago, Martin Nygaard Jensen1709160997 said:

 

Did you ever get this working? I have ".../install_mcsio_driver /mastermcsimage /optimize /quiet..."  in my commandline and the MCS optimization isn't working for me either.

I didn't have to reinstall the master image since then, therefore I didn't use the CLI options. Updating the VDA purely via GUI was without problem since then. I guess it was a bug in the 1906.2 installer (or in combination with what ever version was installed before). So I used the VDACleanupUtility, and then my CLI options worked. This is what I used for 1906.2, might not work with current version:

 

XenDesktopVDASetup.exe /components vda /controllers "controller1.host.name controller2.host.name" /disableexperiencemetrics /enable_hdx_ports /enable_hdx_udp_ports /enable_real_time_transport /enable_framehawk_port /enable_remote_assistance /exclude "AppDisks VDA Plug-in","Personal vDisk","Citrix Personalization for App-V - VDA","Citrix Files for Windows","Citrix Files for Outlook" /install_mcsio_driver /masterimage /optimize

Check here for current options: https://docs.citrix.com/en-us/citrix-virtual-apps-desktops/install-configure/install-command.html (/mastermcsimage and /masterimage are synonymous)

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...