Jump to content
Updated Privacy Statement
  • 0

HDX Optimization Pack 2.4 with Skype for Business 2015 in VDI infrastructure based on XenDesktop 5.6 does not work properly.


Anton Ivonin

Question

We have VDI infrastructure based on XenDesktop 5.6 (Windows Server 2008 R2). Every VDI client has Windows 7 x64 with installed Citrix HDX Realtime Connector v 2.4. Our users using for connection "thin client" based on Windows 7 x64 where is installed Citrix HDX RealTime Media Engine 2.4 and Citrix Reciver 4.2 . When I start Skype for Business in VDI client, the Citrix HDX Realtime Connector tell me that it is connected. Everything works fine, but one scenario does not work as we expect. 

 

When I try to make a video call from Skype for Desktop from the Internet to Skype for Business in VDI we have troubles with video on VDI client "black square instead of video" (screen shoot is attached).


Does anyone know how to fix this?

 

P.S. Audio call from Skype for Desktop from the Internet to Skype for Business to VDI works fine.

 

 

 

black.png

Link to comment

9 answers to this question

Recommended Posts

  • 0
18 hours ago, Anton Ivonin said:

We have VDI infrastructure based on XenDesktop 5.6 (Windows Server 2008 R2). Every VDI client has Windows 7 x64 with installed Citrix HDX Realtime Connector v 2.4. Our users using for connection "thin client" based on Windows 7 x64 where is installed Citrix HDX RealTime Media Engine 2.4 and Citrix Reciver 4.2 . When I start Skype for Business in VDI client, the Citrix HDX Realtime Connector tell me that it is connected. Everything works fine, but one scenario does not work as we expect. 

 

When I try to make a video call from Skype for Desktop from the Internet to Skype for Business in VDI we have troubles with video on VDI client "black square instead of video" (screen shoot is attached).


Does anyone know how to fix this?

 

P.S. Audio call from Skype for Desktop from the Internet to Skype for Business to VDI works fine.

 

 

 

black.png

 

Hi. 

 

RTOP is only support with XenDesktop 7.x. Here is the lifecycle information: 

https://support.citrix.com/article/CTX200466 

 

On top of this RTOP 2.4 requires Receiver 4.9+ 

Regards,
Daniel 

Link to comment
  • 0
On 9/9/2019 at 1:46 PM, Daniel Szomboti said:

 

Hi. 

 

RTOP is only support with XenDesktop 7.x. Here is the lifecycle information: 

https://support.citrix.com/article/CTX200466

 

On top of this RTOP 2.4 requires Receiver 4.9+ 

Regards,
Daniel 

Daniel,

Could you please confirm that video call from the Internet via Skype for Desktop to Skype for Business is worked with RTOP 2.4+ and XenDesktop 7.6? I cannot find information about this.

Link to comment
  • 0
3 hours ago, IOG Support said:


I am really is waiting for your test.....please let me know when you done it. 


Ok, spoke to the PM and dev's. Officially only Skype for business is supported for calls and video. Developers said they tested calls to skype for business home edition in the past and it worked but as I said it's not a supported scenario so we will not be able to troubleshoot further. Sorry. 

Link to comment
  • 0
 
 
 
1
7 minutes ago, Daniel Szomboti said:


Ok, spoke to the PM and dev's. Officially only Skype for business is supported for calls and video. Developers said they tested calls to skype for business home edition in the past and it worked but as I said it's not a supported scenario so we will not be able to troubleshoot further. Sorry. 

When you said "skype for business home edition" what does it mean? I don't know edition "skype for business home edition" 


Could you explain more, please?

Link to comment
  • 0
39 minutes ago, Daniel Szomboti said:

Skype for desktop - the one people install at home. I thought thats what you meant in above statement. 

Ok, I want to make a conclusion.

It turns out that in any VDI infrastructure with any version of XenDesktop and RTOP video and audio call not supported from the Internet via Skype for Desktop to Skype for Business. 

Is that correct?

Link to comment
  • 0
14 hours ago, IOG Support said:

Ok, I want to make a conclusion.

It turns out that in any VDI infrastructure with any version of XenDesktop and RTOP video and audio call not supported from the Internet via Skype for Desktop to Skype for Business. 

Is that correct?


That is correct.

As said audio seems to always work from my tests, video is black (probably due to a codec mismatch - will try look at logs ove the next weeks) but bottom line the setup is not supported - RTOP is for Skype for Business only. Sorry. 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...