Jump to content
Welcome to our new Citrix community!

Netscaler ADV 12.1 Virtual Appliance Stopping Load Balancing


David Castro

Recommended Posts

Hello!

 

We currently have netscaler VPX 10, everything works fine but we have to update for the latest one. We downloaded the ADC 13 one, configured everything, tested and worked fine. Some hours later every virtual server stopped working, all services up, monitors up IP pinging but the website did not open.

 

We called Citrix and they recommended the 12.1 version. Ok, we deployed everything again as new and worked fine for one day, the next day, nothing working again. The same, services and monitors up and running, ping working etc but website not working.

 

We disable everything in the old netscaler to enable on the new one. 

 

We have 2 netscalers ADC virtual appliance 12.1 configured HA. 

 

Does someone know how to fix it?

 

Thanks in advance!

Link to comment
Share on other sites

What version did you upgrade from originally?  (As some gateway to storefront communication dependencies changed at 11.1). 

 

Did you verify clock and license type (just in case it is a factor)?  Which license file are you using and can you confirm it includes LB and gateway functions? (Again depending on original file and upgrade there could be an unexpected discrepancy.)

 

Is internal storefront lb working but failing through gateway or all access to storefront is failing?
You are in an ha pair; are you confirming that you are on the primary ADC and not experiencing an unexpected failover condition or other ha issues.

 

You can check syslog and nslog for events that may identify something else is going on.

# syslog:

cd /var/log/

tail -f ns.log | grep -v CMD_EXECUTED

tail ns.log | grep error -i

# syslog will show ha related events and possible service up/down events.

 

# nslog

cd /var/ns.log

nsconmsg -K newnslog -d event

nsconmsg -K newnslog -d consmsg

# especially in this one look for events referring to a service down related to the storefront FQDN of the lb vip as opposed to the backend destinations...

# or you may see networking issues indicated

 

 

 

 

 

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...