Jump to content
Welcome to our new Citrix community!
  • 0

Unattended Hypervisor / XenServer installation - Systemd


Ceacutedric Sadowski

Question

Hi everybody,

 

Have a question about unattended installation of Citrix XenServer 7.1. Everything is OK but when I have completed the installation, I have a post-script to execute.

Refer to this KB : https://support.citrix.com/article/CTX217700, i've created 2 scripts to make my custom post installation but experienced an error during this step.

 

systemctl status postinstall.service
● postinstall.service - Customizing XenServer - Post install script
   Loaded: loaded (/etc/systemd/system/postinstall.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Mon 2019-08-26 10:49:44 CEST; 11min ago
  Process: 3475 ExecStart=/tmp/first-boot-script.sh (code=exited, status=1/FAILURE)
 Main PID: 3475 (code=exited, status=1/FAILURE)

 

Files are present :

 

ls -l
total 28
-rwxrwxrwx 1 root root 6671 Aug 23 09:48 first-boot-script.sh
drwxrwxrwx 5 root root 4096 Apr 22  2016 lib64
-rw-r--r-- 1 root root    0 Aug 26 10:49 master
-rw-r--r-- 1 root root    0 Aug 26 10:49 null
-rw-r--r-- 1 root root 5182 Aug 26 10:38 post-executed
-rw-r--r-- 1 root root  775 Aug 26 10:35 qaucli_082619-08_35_26.log
drwx------ 3 root root 4096 Aug 26 10:51 systemd-private-f92e76eaeb2246d49713881d24221eea-ntpd.service-eIKCPc

 

ls -l
total 1984
-rw------- 1 root root   273028 Aug 26 11:00 audit.log
drwxr-xr-x 2 root root     4096 Dec  3  2018 blktap
-rw-r--r-- 1 root root    12455 Aug 26 10:49 boot.log
-rw------- 1 root utmp        0 Aug 26 10:34 btmp
drwxr-xr-x 2 root root     4096 Dec  9  2015 cluster
-rw------- 1 root root      685 Aug 26 11:01 cron
-rw------- 1 root root    66972 Aug 26 11:03 daemon.log
-rw-r--r-- 1 root root   122406 Aug 26 10:49 dmesg
drwxr-xr-x 3 root root     4096 Aug 26 10:38 installer
-rw-r--r-- 1 root root     2552 Aug 26 10:49 interface-rename.log
-rw------- 1 root root   177215 Aug 26 10:50 kern.log
-rw-r--r-- 1 root root 38273316 Aug 26 11:00 lastlog
drwx------ 2 root root    16384 Aug 26 10:32 lost+found
-rw------- 1 root root        0 Aug 26 10:35 maillog
-rw------- 1 root root        0 Aug 26 10:35 messages
drwxr-xr-x 2 ntp  ntp      4096 Nov 14  2016 ntpstats
drwxr-xr-x 2 root root     4096 Dec  3  2018 openvswitch
-rw-r--r-- 1 root root      674 Aug 26 10:49 ovs-ctl.log
-rw-r--r-- 1 root root        0 Aug 26 10:49 ovsdb-server.log
-rw-r--r-- 1 root root        0 Aug 26 10:49 ovs-vswitchd.log
-rw-r--r-- 1 root root      198 Aug 26 10:49 ovs-xapi-sync.log
-rw-r--r-- 1 root root     5047 Aug 26 10:50 pbis-open-install.log
-rw-r--r-- 1 root root      448 Aug 26 10:49 restoreeswitchcfg.log
drwxr-xr-x 2 root root     4096 Aug 26 10:49 sa
drwx------ 3 root root     4096 Aug 26 10:34 samba
-rw------- 1 root root     1909 Aug 26 11:02 secure
-rw------- 1 root root    34581 Aug 26 10:55 SMlog
-rw------- 1 root root        0 Aug 26 10:35 spooler
-rw------- 1 root root        0 Aug 26 10:34 tallylog
-rw------- 1 root root     4365 Aug 26 10:59 user.log
-rw-rw-r-- 1 root utmp     3456 Aug 26 11:00 wtmp
-rw------- 1 root root     1325 Aug 26 10:49 xcp-rrdd-plugins.log
drwxr-xr-x 2 root root     4096 Aug 26 10:49 xen
-rw-r--r-- 1 root root        0 Aug 26 10:49 xen_post_install.log
-rw------- 1 root root  1112559 Aug 26 11:03 xensource.log
-rw------- 1 root root    14273 Aug 26 10:49 xenstored-access.log
-rw------- 1 root root    30041 Aug 26 10:35 yum.log

 

When I try to execute /tmp/first-boot-script, it works perfect with no errors !

 

Could you help me please ?

 

Regards.

 

 

post-script.sh

first-boot-script.sh

Link to comment

1 answer to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...