Jump to content
Updated Privacy Statement
  • 0

HTML5 Workspace App 1908 being blocked by uBlock Origin


FRASER ROBERTSON

Question

Has anyone else encountered this? We just upgraded our HTML5 receiver from 19.1 to 1908 and now when users try to connect in a browser with uBlock they are getting a white screen and the desktop doesn't load. It looks like there is a call-back to googletagmanager.com which gets blocked. 

 

Is this call meant to be in the client or has it been left in this build accidentally. I'd really rather not have to ask our users to disable their ad-blockers to use an internal service.

Link to comment

19 answers to this question

Recommended Posts

  • 1

Hi Karanb, thanks for repying.

 

The steps you describe to disable it via configuration.js seem to be for the Citrix Workspace app for Chrome.

This issue being discussed applies to the HTML5 reciever. I'm using Firefox at the moment to connect to it, no Chrome involved.

We saw that inside the HTML5 receiver a configuration.js exists with this setting, we changed that, restarted the server and tested it, with no change noticeable.

 

As stated in https://docs.citrix.com/en-us/receiver/html5/current-release/configure.html I set the checkmark to CEIP to off, logged off my session, logged in again, no change.

 

  • Like 1
Link to comment
  • 0

Hi,

We are able to reproduce the issue and are currently looking at the probable fixes. 

As a workaround, could you add the following line in "My Filters" of UBlock - @@||www.googletagmanager.com^$script

 

This should allow the sessions to launch. Let us know if this worked for you.

 

Thanks and Regards,

Karan

Link to comment
  • 0

Hi Janssenm,

 

We are addressing the issue and the fix for this should be part of our next release.

 

You can disable it by following the below steps (You won't need to add the Filter in UBlock with the below settings) :

 

For Citrix Workspace app Chrome versions 1907 and earlier, set the enabled attribute under ceip to false in the configuration.js file.

 

'ceip':{

    'enabled':false,

}

 

 

For Citrix Workspace app Chrome versions 1907 and later, set the enabled attribute under analytics to false in the configuration.js file.

 

'analytics':{

    'enabled':false,

}

Link to comment
  • 0

We tested Citrix Workspace App for HTLM5 version 1909.  Now we can start a session, without needing to whitelist an external URL.

So referring to the main question of this thread, this could be marked as solved, but that would be up to @FRASER ROBERTSON who asked it.

 

But.. there is a but, from my side.

Although whitelisting is not needed anymore, the session still want's to connect to googletagmanager.com.

When whitelisting googletagmanager.com, no other URL is requested (version 1908 wanted to go to google-analytics.com after whitelisting)

So people not blocking scripts and/or ads (the majority of end-users who aren't aware), will still request googletagmanager.com in version 1909.

I wonder why this is needed.

 

 

Link to comment
  • 0
On 8/22/2019 at 11:59 PM, FRASER ROBERTSON said:

Has anyone else encountered this? We just upgraded our HTML5 receiver from 19.1 to 1908 and now when users try to connect in a browser with uBlock they are getting a white screen and the desktop doesn't load. It looks like there is a call-back to googletagmanager.com which gets blocked. 

 

Is this call meant to be in the client or has it been left in this build accidentally. I'd really rather not have to ask our users to disable their ad-blockers to use an internal service.

The issue has been fixed and users need not remove adblock extension.

Can you please update to the latest version of HTML5 Receiver ?

Link to comment
  • 0
On 4/2/2020 at 12:56 AM, Maik Ludwig said:

We have the same problem.
The Workspace App for HTML5 2002 is installed on our Storefront Server.
After disabling uBlock it works. But some customers still use the Internet Explorer. There the error also occurs, but there is no uBlock at all.

Hi Maik,

 

Thank you for reporting the issue. We are currently working on the fix and should be available in the next GA of HTML5 CWA.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...