Jump to content
Welcome to our new Citrix community!
  • 0

VirtualStore folder not created when using App Layering


Terry Rebstein

Question

Hi, we have an issue where we are moving an application to app layering as an elastic layer. The issue is that it is a legacy application and references an ini file in C:\Windows. In the current production (non app layering) environment it works fine as a folder %userprofile%\AppData\Local\VirtualStore\Windows\inifile.ini gets created. However in app layering it does not create the VirtualStore folder and subsequent ini and users configurations are not persisted.

 

This seems very similar to this discussion thread i found-https://discussions.citrix.com/topic/370639-bug-citrix-personal-vdisk-disables-the-windows-virtualstore/

 

Is there anything we can do to resolve this? We really need this as an elastic layer due to the use case consolidation we are attemping. The application is based on Powerbuilder.

 

Link to comment

2 answers to this question

Recommended Posts

  • 0

Which version of App Layering are you working with? When is the folder created, i.e. during installation, after a user logs in, other? Does it work if the app layer is included in the image? Does the layer pass the Elastic Fit test? Does it work if you login with the local administrator account? Thank for the link, but the PVD and Elastic Layering processes are very different.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...