Jump to content
Welcome to our new Citrix community!
  • 0

Host to client redirection not working (XenApp 7.15 LTSR)


J Lo

Question

Using XenApp 7.15 LTSR on Windows Server 2016

Windows Server 2016 (VDAs) are domain joined

Client side are non-domain join

Client side has IE set as default web browser

 

I follow the guide at

https://docs.citrix.com/en-us/xenapp-and-xendesktop/7-15-ltsr/general-content-redirection/host-to-client-redirection.html

and 

https://support.citrix.com/article/CTX106094

 

Below steps were made

1. Citrix Studio with below policies enabled

Allow Bidriectional Content Redirection > Allowed

Allowed URLs to be redirected to Client > Use default value

2. Registry changed according to "ServerFTA.reg"

3. Group policy changed according to "ServerFTAdefaultPolicy.xml"

4. In VDAs, default web browser set to use Internet Explorer

5. In VDAs, run "gpupdate /force"

6. Client side re-logon

7. In Outlook (one of the XenApp app), create a draft email with "www.google.com" in the email content

8. Click on the hyperlink. The website opened by IE in VDA instead of the IE at client side

 

Link to comment

8 answers to this question

Recommended Posts

  • 1

You may try to add this registry key on the server:
ForceShellExecute=1


If you are running 32-bit Office on 64-bit Windows server:
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\9.0\Common\Internet

 

If you are running 64-bit Office on 64-bit Windows, the registry key will be:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\9.0\Common\Internet

 

Remember it’s always under \9.0\

 

Regards

 

Thomas Tran

https://www.mqtechnologies.com

 

  • Like 1
Link to comment
  • 1

Do you have other browser than Microsoft installed on the server? If yes, there may be a conflict with default browser setting. Since Windows 2012, 2016 Microsoft has changed the registry setting, it becomes very complicated to change. You may consult these topics for some useful information:

https://discussions.citrix.com/topic/385357-users-are-prompted-to-specify-internet-browser-when-you-click-on-a-link-in-outlook-2016/

 

https://discussions.citrix.com/topic/381964-setting-the-default-browser/

 

If the default browser is MS Edge or IE you may need to associate the command to these 2 keys:

HKEY_LOCAL_MACHINE\http 

HKEY_LOCAL_MACHINE\IE.HTPP

 

E.g:

HKEY_LOCAL_MACHINE\http\shell\open\command] @="\"C:\\Program Files (x86)\\Citrix\\system32\\iexplore.exe\" %1"

HKEY_LOCAL_MACHINE\IE.HTTP\shell\open\command] @="\"C:\\Program Files (x86)\\Citrix\\system32\\iexplore.exe\" %1"

 

The idea is to set Citrix Server FTA and http protocol handler so when users click on the link it will pass the URL to the Citrix program:

"C:\\Program Files (x86)\\Citrix\\system32\\iexplore.exe\" URL

Then it will be forwarded to the client side.

 

For example, we have a program named RemoteExecuter.exe that is used for URL host to client redirection on RDS, to associate it with http protocol (no other browser installed on the server, we use this setting (the keys must be renamed and recreated with these values so no other values can change the behavior):

 

The first block (@="URL:HyperText Transfer Protocol") is mandatory since Window 2016, we got a lot of headache because of that

 

Windows Registry Editor Version 5.00
[HKEY_CLASSES_ROOT\http]
@="URL:HyperText Transfer Protocol"
"URL Protocol"=""
"EditFlags"=dword:00200002


[HKEY_CLASSES_ROOT\http\shell\open\command]
@="\"C:\\Program Files (x86)\\MQTechnologies\\RemoteExecuter\\RemoteExecuter.exe\" %1"
[HKEY_CLASSES_ROOT\IE.HTTP]
@="URL:HyperText Transfer Protocol"
"URL Protocol"=""
"EditFlags"=dword:00200002

 

[HKEY_CLASSES_ROOT\IE.HTTP\shell\open\command]
@="\"C:\\Program Files (x86)\\MQTechnologies\\RemoteExecuter\\RemoteExecuter.exe\" %1"

 

You can do similar with "C:\\Program Files (x86)\\Citrix\\system32\\iexplore.exe\"

 

Regards

 

Thomas Tran

https://www.mqtechnologies.com

 

 

  • Like 1
Link to comment
  • 0

Hello Thomas,

Still no go. Did I miss something? Below are what I did:

1. Remove "Firefox" and "Internet Explorer" in "HKLM\SOFTWARE\RegisteredApplications" and "HKLM\SOFTWARE\Wow6432Node\RegisteredApplications". Confirm both were gone in "Control Panel > Set Default Programs"

2. In "Control Panel > Set Default Programs". Found that "HTTP" and "HTTPS" are associated to "ServerFTA".

3. In "HKLM\SOFTWARE\Classes\http\shell\open\command" and "HKLM\SOFTWARE\Classes\https\shell\open\command". Confirm the path set to the IE inside Citrix folder.

4. In "HKLM\SOFTWARE\Classes\IE.HTTP\shell\open\command" and  "HKLM\SOFTWARE\Classes\IE.HTTPS\shell\open\command". Changed the path set to the IE inside Citrix folder.

5. Confirm the settings of "4" above is same to those in "HKEY_CLASSES_ROOT".

 

In [HKEY_CLASSES_ROOT\http]. A "REG_SZ" name "AppUserModelID" has value "Microsoft.InternetExplorer.Default". Is this matter?

 

This problem not just happen in Outlook. Other MS Office suite apps as well. I think the Host to client redirection in my VDA is not working at all.

Link to comment
  • 0

I recommend that you rename

[HKEY_CLASSES_ROOT\http] and [HKEY_CLASSES_ROOT\IE.HTTP]

to

[HKEY_CLASSES_ROOT\http_bak] and [HKEY_CLASSES_ROOT\IE.HTTP_bak]

 

and recreate them with these values, nothing else.

 

 Windows Registry Editor Version 5.00

 

[HKEY_CLASSES_ROOT\http]
@="URL:HyperText Transfer Protocol"
"URL Protocol"=""
"EditFlags"=dword:00200002

 

[HKEY_CLASSES_ROOT\http\shell\open\command]
@="\"C:\\Program Files (x86)\\Citrix\\system32\\iexplore.exe\" %1"

 

[HKEY_CLASSES_ROOT\IE.HTTP]
@="URL:HyperText Transfer Protocol"
"URL Protocol"=""
"EditFlags"=dword:00200002

[HKEY_CLASSES_ROOT\IE.HTTP\shell\open\command]
@="\"C:\\Program Files (x86)\\Citrix\\system32\\iexplore.exe\" %1"

 

By the way, if you have set ServerFTA as default program, this key will be used:

[HKEY_CLASSES_ROOT\ServerFTAHTML\shell\open\command]
@="\"C:\\Program Files (x86)\\Citrix\\system32\\iexplore.exe\" %1"

 

Did you add URL to ValidSites ? (https://docs.citrix.com/en-us/xenapp-and-xendesktop/7-15-ltsr/general-content-redirection/host-to-client-redirection.html)

 

I'm sorry for the incorrect information in my previous post:

ForceShellExecute=1

is necessary only for links inside Office document like Word, Excel, PowerPoint. No need for Outlook.

 

In Outlook email, it will be handler by default. We only need to associate with Citrix "C:\\Program Files (x86)\\Citrix\\system32\\iexplore.exe\"

 

Regards

Thomas Tran

https://www.mqtechnologies.com

 

Link to comment
  • 0

Sorry Thomas,

My topic title may mislead you. My topic said "Host to client redirection". But my first post said enabled "Allow Bidirectional Content Redirection" and "Allowed URLs to be redirected to Client". 

"Host to client redirection" is now enabled and works.

Which means is "Bidirectional Content Redirection" not working. My testing client side is non-domain joined Windows 10. Is this matter?

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...